STS: No Error Returned When VSS Shadow Folder Is Inaccessible (318769)



The information in this article applies to:

  • SharePoint Team Services from Microsoft
  • FrontPage 2002 Server Extensions from Microsoft

This article was previously published under Q318769

SYMPTOMS

If SharePoint Team Services or the FrontPage Server Extensions are configured to use Visual SourceSafe (VSS) integration with a project, and that project uses shadow folders, when you check in a file, the changes are not saved, and no warning or error message is displayed.

CAUSE

This program occurs when you do not have NT File System (NTFS) or share access to the shadow folder.

Visual SourceSafe detects that you do not have read/write access to the shadow folder, and returns an error; however, neither SharePoint Team Services nor FrontPage Server Extensions detects the error. Therefore, when you check in files, any changes that you made are lost, because the files are not replicated to the shadow folder.

RESOLUTION

To resolve this issue, an administrator must grant all users access to the shadow folder if they have read/write access in Microsoft Visual SourceSafe Administrator.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to troubleshoot FrontPage and VSS integration, click the article numbers below to view the articles in the Microsoft Knowledge Base:

238252 Enable Event Error Logging for FrontPage 2000 and SourceSafe

243623 Errors with Source Control Integration When Checking Out Files


Modification Type:MajorLast Reviewed:10/29/2003
Keywords:kbbug kbpending KB318769