Cannot access attachments (318515)



The information in this article applies to:

  • Microsoft Outlook 2000, Service Release 1 (SR-1)

This article was previously published under Q318515
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you use Outlook 2000 Service Release 1 (SR-1) or Microsoft Outlook 2000 Service Release 1a (SR-1a) and you open a message, you may receive the following error message:
Outlook blocked access to the following potentially unsafe attachments: [...]
NOTE: Both Outlook 2000 SR-1 and Outlook 2000 SR-1a include a new security feature that blocks attachments that are potentially unsafe. This security feature provides an additional level of protection against malicious messages.

CAUSE

This behavior occurs because the message contains a file type that is blocked by either Outlook 2000 SR-1 or Outlook 2000 SR-1a.

RESOLUTION

Although Outlook 2000 SR-1 or Outlook 2000 SR-1a blocks access to the attachment, the attachment still exists in the message. Use one of the following recommended methods to obtain access to the attached file:
  • Request that the sender post or save the attachment to a file share and send you the link to it.

    -or-
  • Request that the sender use a file compression utility that changes the file name extension. For a list of third-party compression products, click the article number to view the following Microsoft Knowledge Base article:

    291637 Attachments are not compressed by Outlook



    -or-
  • Request that the sender rename the file name extension and send it to you. After you receive the renamed attachment, you can rename the file with the original extension.
If the previously recommended methods do not meet your requirements, you may use the following method:
  • If you are in a Microsoft Exchange Server environment and your administrator has configured the Outlook Security settings, ask the administrator to modify the security settings for your mailbox.
If the previous methods do not meet your requirements, you may resolve this problem by modifying the registry after you install the fix that is available from Microsoft (for more information, see the "How to Customize the Attachment Security Behavior" section of this article).

NOTE: To use this method, one of the following conditions must be true:
  • Outlook is running outside an Exchange Server environment.

    -or-
  • In an Exchange Server environment, the administrator has not configured the Outlook Security settings to disallow changes to the attachment security behavior.

How to Customize the Attachment Security Behavior

To customize the attachment security behavior in Outlook 2000 SR-1 and Outlook 2000 SR-1a, install a fix, and then modify the registry.

To resolve this problem, obtain the latest service pack for Microsoft Office 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

276367 How to obtain the latest Office 2000 service pack

The English-language version of this fix has the following file attributes or later:
   Date           Time  Size       File name     
   --------------------------------------------------
   26-Feb-2002    00:56 2,641,920  Outlook.msp
   26-Feb-2002    01:03 7,715,328  Outlook_admin.msp
				
After the fix is installed, the files have the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size      File name
   --------------------------------------------------------------
   14-Jun-2000  17:11  1.0.3.27           41,472  Bjablr32.dll     
   14-Jun-2000  17:12  3.2.0.27           61,952  Bjlog32.dll      
   08-Jan-2001  21:37  1.0.3.28           98,304  Bjsrch32.dll     
   28-Apr-1999  01:12  1.0.0.1            32,768  Cabextract.exe   
   19-Jun-2000  18:49  5.5.2652.65       716,560  Cdo.dll          
   19-Jun-2000  18:12  5.5.2652.65       808,720  Cdo.dll_0004
   02-Dec-2001  02:00  9.0.0.5930        127,027  Contab32.dll
   14-Jun-2000  17:14  1.0.3.27          183,808  Emablt32.dll     
   31-Aug-2000  19:43  5.5.3142.0        154,112  Emsabp32.dll
   05-Oct-2001  10:33  5.5.3165.0        594,192  Emsmdb32.dll
   02-Jun-2001  01:15  5.5.3159.0        131,344  Emsui32.dll
   02-Jun-2000  10:45  9.0.0.4201         86,067  Envelope.dll     
   18-Dec-2001  23:19  5.5.3167.0        540,944  Exsec32.dll
   05-Apr-2000  19:02  9.0.0.4005        192,561  Mimedir.dll      
   21-May-2001  18:20  5.5.3157.0        792,576  Msmapi32.dll
   21-May-2001  18:16  5.5.3157.0        623,104  Msmapi32.dll
   08-Jul-2000  03:07  5.5.3138.0        602,384  Mspst32.dll
   08-Jul-2000  03:03  5.5.3138.0        528,656  Mspst32.dll
   01-Feb-2000  01:26  9.0.0.3731        196,661  Oladd.fae
   23-May-2000  15:20                    150,690  Olexchng.aw
   30-May-2000  18:53                     26,643  Olsec9.chm
   22-May-2000  23:35                    170,617  Olxchng9.chm
   08-Feb-2001  17:18  5.5.3153.0        454,144  Omi9.dll
   08-Feb-2001  17:21  5.5.3153.0        548,352  Omint.dll
   13-Nov-2001  11:45  8.30.3165.0       782,608  Outex.dll        
   23-May-2000  23:19                    554,068  Outlhlp.aw
   22-Feb-2002  08:18  9.0.0.6221      5,337,138  Outllib.dll      
   01-Sep-2001  00:02  9.0.0.5630      1,675,315  Outllibr.dll     
   17-Jun-2002  09:34                  6,991,696  Pcw_cab_h8000_1.cab
   13-Jul-2001  09:48  9.0.5512.0        368,691  Pstprx32.dll
   21-Jun-2001  22:01  9.0.0.5421         73,772  Rm.dll           
   02-Jun-2000  11:30  9.0.0.4201         65,586  Sendto9.dll
				
This fix is also available in the French language.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you apply this fix, use the Level1Remove and Level1Add registry keys to customize the attachment security behavior.

Follow these steps to use the Level1Remove registry key to allow Outlook 2000 to open file types that would otherwise be blocked:
  1. Quit Outlook 2000 if it is running.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Verify that the following key exists. If it does, go to step 5.

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Security

    If the key path does not exist, create the key path. To create the key path, locate and then select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft

    1. Click the Edit menu, click New, and then click Key.
    2. Type Office, and then press the ENTER key.
    3. Click the Edit menu, click New, and then click Key.
    4. Type 9.0, and then press the ENTER key.
    5. Click the Edit menu, click New, and then click Key.
    6. Type Outlook, and then press the ENTER key.
    7. Click the Edit menu, click New, and then click Key.
    8. Type Security, and then press the ENTER key.
  5. Click the Edit menu, click New, and then click String Value.
  6. Type the following name for the new value: Level1Remove

  7. Press the ENTER key.
  8. Right-click the new string value name, and then click Modify.
  9. Type the extension of the file type that you want to allow access to from Outlook 2000 as follows: .exe

    To specify multiple file types, use the following format:

    .exe; .com
  10. When you are finished, click OK.
  11. Exit Registry Editor.
  12. Restart your computer.
When you start Outlook 2000, the file types specified in the Windows Registry are accessible.

NOTE: Microsoft recommends that you only enable the file types that you need for access. If a particular file type is received rarely, Microsoft recommends that you give Outlook 2000 temporary access to the file type in question and then undo the changes that you made to the Windows Registry to reconfigure to the blocked state.

Follow these steps to use the Level1Add registry key to configure Outlook 2000 to not open file types that would otherwise be assessable:
  1. Quit Outlook 2000 if it is running.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Verify that the following key exists. If it does, go to step 5.

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Security

    If the key path does not exist, create the key path. To create the key path, locate and then select the following key:

    HKEY_CURRENT_USER\Software\Microsoft

    1. Click the Edit menu, click New, and then click Key.
    2. Type Office, and then press the ENTER key.
    3. Click the Edit menu, click New, and then click Key.
    4. Type 9.0, and then press the ENTER key.
    5. Click the Edit menu, click New, and then click Key.
    6. Type Outlook, and then press the ENTER key.
    7. Click the Edit menu, click New, and then click Key.
    8. Type Security, and then press the ENTER key.
  5. Click the Edit menu, click New, and then click String Value.
  6. Type the following name for the new value: Level1Add

  7. Press the ENTER key .
  8. Right-click the new string value name, and then click Modify.
  9. Type the extension of the file type that you want to block access with Outlook 2000 as follows: .zzz

    To specify multiple file types, use the following format:

    .zzz;.yyy

  10. When you are finished, click OK.
  11. Exit Registry Editor.
  12. Restart your computer.
When you start Outlook 2000, the file types that you specified in the Windows Registry are blocked.

Microsoft Exchange Server Environment

If you run Outlook in an Exchange Server environment, your administrator can change the default attachment security behavior. For additional information about how to configure Outlook 2000 in an Exchange Server environment, click the following article number to view the article in the Microsoft Knowledge Base:

263297 Administrator info about e-mail security features

STATUS

This behavior is by design. This problem was first corrected in Microsoft Office 2000 Service Pack 3 Service Pack 3.

MORE INFORMATION

For additional information about the Outlook E-mail Security Update, click the following article number to view the article in the Microsoft Knowledge Base:

262631 Information about the Outlook E-mail Security update


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbOffice2000SP3Fix kbbug kbfix KB318515