"SERVICES.EXE Terminated Unexpectedly with Status Code 128" Error Message When You Start Windows 2000 (318447)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1

This article was previously published under Q318447
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Windows 2000 Server and the "Preparing network connections" message is displayed, you may receive the following error message:

The system is shutting down. Please save all work in progress and log off. Any unsaved changes will be lost. This shutdown was initiated by NT AUTHORITY\SYSTEM.

The system process C:\WINNT\SYSTEM32\SERVICES.EXE terminated unexpectedly with status code 128. The system will shut down and restart.

CAUSE

This issue may occur if there are incorrect references to shared folders in the following registry key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Shares

This issue may also occur if a stale security value is left for shares that no longer exist under the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Shares\Security

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, follow these steps:
  1. Restart the computer in Safe mode:
    1. Restart the computer.
    2. Press F8 when you receive the "Please select the operating system to start" message.
    3. On the Windows Advanced Options menu, use the arrow keys to select Safe Mode, and then press ENTER.
    4. If you are running other operating systems on the computer, use the arrow keys to select Microsoft Windows 2000 in the list that is displayed, and then press ENTER.
  2. Click Start, click Run, type regedit in the Open box, and then press ENTER.
  3. Locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Shares

  4. Back up the registry key:
    1. On the Registry menu, click Export Registry File.
    2. In the File name box, type Shares_RegKey, and then click Save.

      This step saves the Shares registry key to the Shares_RegKey text file, which you can use to restore the key in the future. By default, the file is saved in the My Documents folder. For information about how to restore the key, search Regedit Help for the Import Registry Key topic.
  5. Examine the list of values in the right pane of Registry Editor.

    Notice that the Data column contains the paths to shared folders. For example, you may see a line similar to the following:

    CSCFlags=0 MaxUses=4294967295 Path=E:\NS Permissions=0 Remark= Type=0

    This refers to the E:\NS shared folder.
  6. For each value, use Windows Explorer to make sure that the path displayed in the Data column represents an existing shared folder. Delete all values that do not correspond to shared folders.
  7. Quit Registry Editor, and then restart the computer.

Modification Type:MajorLast Reviewed:7/2/2003
Keywords:kberrmsg kbprb KB318447