IIS May Return HTTP Status 401 Every 30 Days When You Use Kerberos Authentication (318225)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

This article was previously published under Q318225

SYMPTOMS

When you use Windows Integrated and Kerberos authentication, you may receive the following error message every 30 days from Internet Information Services (IIS):
401 access denied
This problem does not occur when you only use NTLM.

CAUSE

IIS caches some credential handles. These handles are removed by a scavenger if they get too old. However, this does not occur for handles that are used to decrypt Kerberos tickets. Because of this, if the handle ages, IIS cannot correctly use the related Kerberos tickets.

WORKAROUND

Disable the use of Kerberos for Windows Integrated authentication. For more information about how to disable Kerberos authentication, click the following article number to view the article in the Microsoft Knowledge Base:

215383 How to configure IIS to support both the Kerberos protocol and the NTLM protocol for network authentication

RESOLUTION

To resolve this problem, obtain the latest IIS cumulative security patch. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

319733 MS02-018: April 2002 Cumulative Patch for Internet Information Services

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with Only One Reboot


Modification Type:MinorLast Reviewed:4/26/2006
Keywords:kbbug kbfix kbQFE kbWin2000PreSP3Fix KB318225