Internet Explorer Stops Responding When You Install a Personal Certificate Through a Terminal Server Session (316266)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Internet Explorer version 6 for Windows NT 4.0

This article was previously published under Q316266

SYMPTOMS

When you install a personal certificate from inside a terminal server session, Internet Explorer may stop responding (hang) in the client session. However, this symptom only occurs if you are using strong private key protection. If you previously turned on the Enable Strong Private Key Protection option, the "Private Key Container" window appears on the console of the terminal server instead of the client session. The client's Internet Explorer session hangs while it is waiting for action to occur on the console. If you click OK in the "Private Key Container Window" on the console, Internet Explorer can continue. The client session then displays a "The import was successful" message.

CAUSE

There is no support in Windows NT Server version 4.0, Terminal Server Edition for bringing up an arbitrary dialog box from one session onto any other session. Because this dialog box is brought up by the Cryptography service (which exists in the console session), it cannot be displayed in the client's session.

WORKAROUND

To work around this problem, use any of the following methods:
  • Install certificates for users on the terminal server rather than through the terminal server session.
  • Do not turn on the Enable Strong Private Key Protection option. If strong private key protection is not turned on, the installation of the certificate can finish correctly.
  • Upgrade to Windows 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbenv kbfix kbprb KB316266