DataLink Mode Is Not Correctly Detected When You Use a Dot4 Printer Port (316079)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q316079

SYMPTOMS

When you use a printer that is configured to print over a DOT4 port, you may receive the following error message when you try to print:
There was an error found when printing the document "Test Page" to DOT4_xxx.
Do you want to retry or cancel the job?
If you click Retry, the document does not print and you may receive the same error message.

CAUSE

This problem occurs because the parallel port driver (Parallel.sys) is not designed to parse device IDs that are presented in the "Command Set:" (long device ID) format. When the PNP process initializes a print device over an ECP parallel port, the parallel port driver reads the device ID field names to identify the print modes (PCL, MLC, and so on) that are supported during either the installation procedure or when the computer starts. If you configure the printer to use a DOT4 port, the device ID may be presented to the parallel port driver as a "Command Set:" or in an abbreviated "CMD:" format.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English-language version of this fix should have the following file attributes or later:
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   14-JAN-2002  12:02  5.0.2195.4834  60,208  Parallel.sys

				

WORKAROUND

To work around this problem, configure the printer to use an LPT port, such as LPT1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kbbug kberrmsg kbfix kbOSWin2000fix kbprint kbWin2000PreSP3Fix kbWin2000sp3fix KB316079