Remote Tools may connect to the wrong Systems Management Server client (315755)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q315755
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use the Systems Manager Server (SMS) Remote Tools feature to remote control an SMS client, the remote control session may connect to a different client than the one that you expected.

CAUSE

This behavior may occur if SMS uses an outdated internet protocol (IP) address from the SMS database when it establishes a Remote Tools session with a client. This may occur if the client's IP address has changed since it last sent up a Data Discovery Record (DDR).

WORKAROUND

To work around this problem, turn on the Windows Networking Logon Discovery feature to receive an updated DDR every time a user logs on or increase the frequency of Heartbeat Discovery. Note that if you turn on Windows Networking Logon Discovery, you may significantly increase the network traffic that the SMS clients generate.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to Obtain the Latest Systems Management Server 2.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

By default, Microsoft Systems Management Server Service Pack 5 (SP5), Remote Tools still has the same behavior, therefore it tries to resolve a client's computer name to an IP address by using both the SMS database and the results of name resolution requests.

However, in SP5 you can configure Remote Tools. To do so:
  1. On the computer where the SMS Administrator Console is installed, start Registry Editor.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Components\SightNT\Viewer

  3. On the Edit menu, click Add Value, and then add the following registry value:

    Value name: ResolutionMethod
    Data type: REG_DWORD
    Value data: 1 or 2

    1 - Remote Tools uses only name resolution to resolve the computer name to an IP address.

    2 - Remote Tools uses only the SMS database to resolve the computer name to an IP address.

    Any value other than 1 or 2 - Remote Tools uses the default behavior as described at the top of this section.

  4. Quit Registry Editor.

    Note In Systems Management Server 2003 (SMS 2003), Remote Tools uses only name resolution to resolve the computer name to an IP address. This feature is not configurable, and changing the Registry value has no affect in SMS 2003.

Modification Type:MajorLast Reviewed:4/5/2004
Keywords:kbBug kbSoftwareDist kbSMS200preSP5fix kbHardware kbfix KB315755