Visio2000: "Memory Could Not Be Read" Error Message When You Open a Saved Visio File (315217)



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q315217

SYMPTOMS

When you try to open a saved Microsoft Visio file, the file may not open. You receive the following error message:
Application Error: The Instructions at "0x77fca2a2" referenced memory at "0xfffffff8". The memory could not be "read."

CAUSE

This issue can occur if you are using a Hewlett Packard (HP) LaserJet 2100 printer with a PCL 6 driver.

Hewlett Packard is aware of the issue with the HP LaserJet 2100 PCL 6 driver.

RESOLUTION

To work around this issue, remove the HP LaserJet 2100 PCL 6 driver, and then install the HP LaserJet 2100 PCL 5 driver.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, and then click Printers and Faxes.
  2. In the Printer and Faxes dialog box, select the HP LJ2100 printer.
  3. On the File menu, click Delete.
  4. Click Add a Printer.
  5. In the Add Printer Wizard dialog box, click Next.
  6. Make sure that Local printer attached to this computer is selected, and then click Next.
  7. Select the proper printer port, and then click Next.
  8. In the Install Printer Software dialog box, click HP in the Manufacturer list.
  9. Click HP LaserJet 2100 PCL5 in the Printers list, and then click Next.
  10. In the Use the Existing Software dialog box, click Replace existing driver.
  11. Follow the Add Printer Wizard instructions.
  12. Start Visio, and then open the file that you were trying to open when this issue occurred.
If you cannot find the proper driver in the Windows driver database, contact Hewlett Packard to download the LaserJet 2100 PCL5e Printer Driver. For information about how to contact Hewlett Packard, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB315217