PRB: HTML Help Does Not Work from VFP Application (314296)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 7.0
This article was previously published under Q314296 SYMPTOMS
After a Visual FoxPro (VFP) 7.0 application is distributed to a computer that does not have VFP 7.0 installed, HTML Help files do not open when accessed from inside the application.
CAUSE
The files FoxHHelp7.exe and FoxHHelpPS7.dll are required in order for HTML Help to work from a distributed VFP 7.0 application.
RESOLUTION
If you are using "InstallShield Express - Visual FoxPro Limited Edition" to install your application, add FoxHHelp7.exe and FoxHHelpPS7.dll in step 2 of the install project. These files should be installed on the development computer in the \Program Files\Common Files\Microsoft Shared\VFP folder. If you do not want to keep them with your application files, you can place them in [CommonFilesFolder]\Microsoft Shared\VFP.
If you are copying the files manually, after bringing them over you need to run the command FoxHHelp7 /regserver on the new computer to put the proper entries in the registry.
REFERENCES
For additional information about building distributions in Visual FoxPro 7.0, see the "InstallShield Express - Visual FoxPro Limited Edition" Help files as well as the article "Walkthrough: Creating a Visual FoxPro Application Setup Program Using InstallShield Express" on the VFP 7.0 CD.
Modification Type: | Minor | Last Reviewed: | 7/11/2003 |
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Keywords: | kbprb KB314296 |
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