A "CAPI" Error Message Occurs After You Install Internet Explorer in French Canadian Windows NT 4.0 SP6a (314142)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer version 6 for Windows NT 4.0

This article was previously published under Q314142

SYMPTOMS

If you install Internet Explorer in Windows NT 4.0 with French Canadian Service Pack 6a (SP6a) and high encryption (128-bit encryption), you receive the following error message after you restart and log on to your computer and Internet Explorer configures the security settings:
CAPI: The install failed. The Rsabase.dll file that is being installed does not match the signature file or the value in the registry

CAUSE

This issue occurs because Rsaenh.dll does not register correctly. The registration problem is caused by a version mismatch between the Rsaenh.dll and Enhsig.dll files.

WORKAROUND

To avoid this problem, rename the %SystemRoot%\System32\Rsaenh.dll and %SystemRoot%\System32\Enhsig.dll files before you install Internet Explorer. This allows Internet Explorer to install its own version of the Rsaenh.dll and Enhsig.dll files from the Iedom.cab cabinet file.

MORE INFORMATION

Windows NT 4.0 French Canadian High Encryption SP6a installs Enhsig.dll version 5.0.1877.9. The version of Enhsig.dll that is included with Internet Explorer is 5.0.1877.8. This file is not copied because the currently installed version is later. This causes a version mismatch between the Rsaenh.dll and Enhsig.dll files.

REFERENCES

For additional information about similar issues, click the article numbers below to view the articles in the Microsoft Knowledge Base:

263178 Error Message: CAPI: The Install Failed. The Rsabase.dll File That Is Being Installed Doesn't Match...

193002 OL98: (IMO) ErrMsg: The Rsabase.dll Does Not Match the Signature


Modification Type:MajorLast Reviewed:11/14/2003
Keywords:kberrmsg kbprb KB314142