Windows Messenger Does Not Transfer Files Correctly Over a Virtual Private Network Connection (313973)



The information in this article applies to:

  • Microsoft Windows Messenger 4.0
  • Microsoft Windows Messenger 4.5
  • Microsoft Windows Messenger 4.6

This article was previously published under Q313973

SYMPTOMS

When you try to transfer a file to another Windows Messenger user, you may not be able to transfer the file. You may receive the following error message:
We could not send this file because the connection is blocked. Please contact your network administrator or Internet service provider; they may be able to enable file transfers.
The user who you are trying to transfer the file to may receive the following error message:
You have failed to receive the file file_name from sending_user
This problem may occur with all of the following Windows Messenger providers:
  • The Microsoft Network (MSN) provider
  • The Exchange provider
  • The Session Initiation Protocol provider

CAUSE

The Windows Messenger client uses a "gethostbyname" Winsock call to determine the IP address. The Windows Messenger client sends that IP address to the remote client, so that the remote client can connect to that address and retrieve the file.

This issue may occur if you are using a virtual private network (VPN) connection. The "gethostbyname" Winsock call may return the local area network (LAN) connection IP address instead of the VPN connection IP address. The remote client tries to connect to that LAN IP address. If the LAN IP address is not available from the remote client's network, the remote client cannot connect.

WORKAROUND

To work around this issue, change the binding order of the connections by moving up the remote access connections so that they are above the LAN connections.

To do this, follow these steps:
  1. In Control Panel, double-click Network Connections.
  2. On the Advanced menu, click Advanced Settings.
  3. On the Adapters and Bindings tab, click Remote Access Connections, and then click the up arrow button until the remote access connections are at the top of the list.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbpending kbprb KB313973