Unchecked buffer in Windows shell could lead to code running (313829)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP5
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP6
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows 98 Second Edition

This article was previously published under Q313829

SYMPTOMS

If a program that uses a URL-handler shell extension is incompletely or incorrectly removed, a malicious user may be able to mount a "buffer overrun" attack on the computer. This attack, if successful, could allow malicious code to run on the computer.

CAUSE

This vulnerability occurs because a Windows component that helps to locate incompletely-removed programs contains an unchecked buffer.

If a program is deleted, or incorrectly removed, a "handler" for that program remains in the Windows registry. A malicious code segment that submits invalid data to this handler can cause the Windows shell to stop responding (hang), or can allow other code to run on the computer in the context of the currently-logged-on user account.

NOTE: This vulnerability does not occur when a program is uninstalled. When a program is uninstalled, Windows un-registers the program handler.

RESOLUTION

Windows 2000

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The following file is available for download from the Microsoft Download Center:
Release Date: March 7, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English version of this fix should have the following file attributes or later:
   GMT-UTC Date Time   Version         Size       File name
   ----------------------------------------------------------
   03-Dec-2001  21:35  5.00.3502.4718  2,338,576  Shell32.dll      
				

Windows NT 4.0

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that you determine are at risk of attack. Evaluate the computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to the computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This hotfix may receive additional testing. If the computer is sufficiently at risk, we recommend that you apply this hotfix now.

To resolve this problem immediately, download the hotfix by following the instructions later in this article or contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The following file is available for download from the Microsoft Download Center:
Release Date: March 7, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on secure servers that prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   GMT-UTC Date Time   Version  Size       File name
   ---------------------------------------------------
   10-Dec-2001  17:53  4.00     1,280,784  Shell32.dll
				

Windows NT Server 4.0, Terminal Server Edition

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that you determine are at risk of attack. Evaluate your computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to your computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This fix may receive additional testing. If your computer is sufficiently at risk, Microsoft recommends that you apply this fix now.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, please visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
Release Date: March 7, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on secure servers that prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   GMT-UTC Date Time   Version  Size       File name

   ---------------------------------------------------
   19-Jan-2002  00:25  4.00     1,300,752  Shell32.dll      
				

Windows NT 4.0 with Active Desktop, Windows 98, and Windows 98 Second Edition

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that you determine are at risk of attack. Evaluate your computer's physical accessibility, network and Internet connectivity, and other factors to determine the degree of risk to your computer. See the associated Microsoft Security Bulletin to help determine the degree of risk. This fix may receive additional testing. If your computer is sufficiently at risk, Microsoft recommends that you apply this fix now.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, please visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled, if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:
Release Date: March 7, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on secure servers that prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   GMT-UTC Date Time   Version        Size       File name
   ----------------------------------------------------------
   02-Jun-1998  16:00  4.72.3110.0       80,864  Advpack.dll      
   30-Nov-1997  22:59                    20,480  Prebind.exe      
   07-Dec-2001  04:25  4.72.3812.600  1,388,816  Shel95.dll       
   07-Dec-2001  05:23  4.72.3812.600  1,719,056  Shelnt.dll       
   02-Jun-1998  16:00  4.71.704.0         2,272  W95inf16.dll     
   02-Jun-1998  16:00  4.71.0016.0        4,608  W95inf32.dll     
				

STATUS

Windows 2000

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Windows 2000. This problem was first corrected in Windows 2000 Service Pack 3.

Windows NT 4.0

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Windows NT 4.0.

Windows NT Server 4.0, Terminal Server Edition

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Windows NT Server 4.0, Terminal Server Edition.

Windows 98 and Windows 98 Second Edition

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Windows 98 and Microsoft Windows 98 Second Edition.

MORE INFORMATION

The Windows Shell provides the basic framework and functionality of the Windows user interface (UI). It is most familiar to users as the Windows desktop, but also provides other functions that help to define the user's Windows session. These functions include organizing files and folders, and providing the means to run programs. Shell extensions are programs that you can install to add to the functionality of Windows Explorer. Explorer is designed to respond in specific ways when a user completes various functions within its shell. When you click an item, Explorer searches for any program modules that have been registered for that event, and if one exists, it attempts to load that module. If the Windows shell is compromised, Windows may stop responding (hang), or control may be taken by a malicious program.

For additional information about this vulnerability, please visit the following Microsoft Web site: For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot


Modification Type:MinorLast Reviewed:11/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix KbSECHack kbSecurity KbSECVulnerability kbshell kbWin2000PreSP3Fix kbWin2000sp3fix KB313829