How to troubleshoot font problems in Office for Mac programs (313535)



The information in this article applies to:

  • Microsoft Entourage 2004 for Mac
  • Microsoft Entourage X
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office v. X for Mac
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft PowerPoint X for Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X for Mac

This article was previously published under Q313535

SYMPTOMS

When you try to start a Microsoft Office for Mac program or open a document for an Office for Mac program, the program's splash screen may appear, but then the program unexpectedly quits.

CAUSE

This problem may occur if there is a damaged or an unsupported font in one of the Fonts folders on your computer.

When a Microsoft Office X for Mac program or a Microsoft Office 2004 for Mac program starts, the program will try to read and to create an optimized list of the fonts that are available in the operating system. If the program finds a damaged font, the program may unexpectedly quit. The following conditions can cause this problem to occur:
  • Duplicate font files.
  • Corrupted Font Cache file.
  • Corrupted font files.
For more information about similar symptoms that have different causes, click the following article numbers to view the articles in the Microsoft Knowledge Base:

312209 MacWDX: Error message when you open Word: The application Microsoft Word has unexpectedly quit

313488 MacOFFX: Program quits after the Project Gallery appears

RESOLUTION

Identify and remove duplicate or corrupted fonts

To resolve this problem, locate and disable the damaged font. To do this, use the following methods in the order that they appear in.

Caution Do not try to change any font folders that you find in the Mac OS X System folder.

Corrupted Font Cache

  1. Open the following folder:

    Hard disk\Users\User_name\Library\Preferences\Microsoft

  2. For Office X, drag the Office Font Cache (10) file to the trash. For Office 2004, drag the Office Font Cache (11) to the trash.
Start Word to determine whether the problem is resolved.

Duplicate font files

  1. On the desktop, click File, New Folder.
  2. Name the new folder Old Fonts.
  3. In the Finder, open the following fonts folders:
    • Hard disk\Mac OS 9 System_folder\Fonts
      Typically, this is Hard disk\System folder\Fonts
    • Hard disk\Library: Fonts
    • Hard disk\Users\User_name\Library\Fonts
  4. Drag any duplicate font files that you find into the Old Fonts folder that you created in step 2.
  5. Restart your computer.
Start Word to determine whether the problem is resolved.

Corrupted font files

  1. In the Finder, open the folder that contains the Mac OS 9 fonts. Typically, the folder that contains the Mac OS 9 fonts is:

    Hard disk\System folder\Fonts

  2. Drag the font files in the Fonts folder to the Old Fonts folder on the desktop that you created in the "Duplicate font files" section.
  3. Restart the computer.
  4. Try to start Microsoft Word to determine whether the problem is resolved.
  5. If the problem still occurs, return the font files from the Old Fonts folder back into the font folder that you used in step 1.
  6. If the problem still occurs, repeat steps 1 through 4, using a Fonts folder that is different from the folder that you used in step 1. Use one of the following Fonts folders:
    • Hard disk\Library\Fonts
    • Hard disk\Users\User_name\Library\Fonts
If the problem does not occur, there is a possible corrupted font located in the font folder that you used in step 1.

To determine the font that is causing the problem, use a process of elimination. Return half of the fonts at a time to the Fonts folder, and then test to see if the problem occurs. To find the damaged font, follow these steps:
  1. Open the Fonts folder you removed the fonts from.
  2. Open the Old Fonts folder, and then click as List on the View menu.
  3. Click the first font file that is listed.
  4. Scroll down about halfway through the list.
  5. Hold the SHIFT key, and then click a font midway in the list. This will select about half of the fonts in the list.
  6. Drag the selected fonts into the Fonts folder that you opened in step 1.
  7. Try to start Word to determine whether the problem is resolved.
  8. If the problem occurs, the damaged font is in the half that you copied into the Fonts folder. To find the damaged font, follow these steps:
    1. Select half the fonts that you copied into the Fonts folder.
    2. Drag these fonts into the Old Fonts folder.
    3. Try to start Word to determine whether the problem is resolved.
    4. If the problem still occurs, repeat steps a through c.
  9. If the problem does not occur in step 7, repeat steps 3 through 8, selecting half of the remaining fonts in the Old Fonts folder.

Problems with the Mac OS X operating system

This problem may also occur if there are problems with the version of the Mac OS X operating system that you have installed on your computer. For more information about how to troubleshoot problems with the Mac OS X operating system, visit the following Apple Web site:

Other possible causes for the problem

Font management software

If you have font management software running on your computer, disable it to see if it is causing the error.

Multiple Macintosh OS 9 System folders

You can rename or delete the additional OS 9 System folders. Only the folder at the root of your hard disk is the primary OS 9 System folder.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbprb KB313535 kbAudEndUser kbAudITPRO