Data loss occurs after you reinstall, repair, or upgrade Windows XP (312368)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q312368
NOTE: The information in this article applies only to computers with Windows XP preinstalled by a computer manufacturer.

SYMPTOMS

You may lose data that is stored in the All Users folder and you may lose default program templates and settings that are stored in the Default User folder after you reinstall, repair, or upgrade Windows XP. Also, Start menu shortcuts, items in the Startup group, and documents, pictures, or music files that are stored in the Shared Documents folder may be missing.

This problem can occur after you perform any of the following actions on a computer that has Windows XP preinstalled by a computer manufacturer (also known as an Original Equipment Manufacturer, or OEM):
  • You reinstall Windows XP in the same folder by clicking Upgrade (Recommended) after you run Winnt32.exe, or by clicking the Install Windows XP link on the "Welcome to Microsoft Windows XP" screen that appears when you insert the Windows XP CD-ROM. This is also known as performing an in-place upgrade or an in-place installation.
  • You repair Windows XP by starting your computer from the Windows XP CD-ROM, pressing ENTER to set up Windows XP, and then pressing R to repair the selected installation.
  • You upgrade the Windows XP Home Edition installation that was preinstalled by your computer manufacturer to the retail version of Windows XP Professional.

CAUSE

This behavior can occur if the Undo_guimode.txt file is present in the Windows\System32 folder on the hard disk on a computer with Windows XP preinstalled by a computer manufacturer when you perform any of the actions that are listed in the "Symptoms" section of this article. The Undo_guimode.txt file is created by the wizard that runs when you first start a computer that has Windows XP preinstalled by a computer manufacturer.

Note The Undo_guimode.txt file is created by OEM Out-of-Box Experience (OOBE) when it should not be. This file should be used only by GUI-mode Setup when Setup restarts. After OOBE creates this file, when Setup performs the upgrade, it sees this file and thinks that it is restarting Setup and deletes the profiles that are listed earlier in this article.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

To resolve this problem, restore the missing data and program shortcuts from a backup.

To prevent this problem from occurring, please see the following Microsoft Knowledge Base article:

312369 You May Lose Data or Program Settings After Reinstalling, Repairing, or Upgrading Windows XP

An update to the OEM Preinstall Kit (OPK) that resolves this issue has been distributed to computer manufacturers.

This update is also available from Microsoft Product Support Services. The English version of this fix should have the following file attributes or later:
   Date        Time   Version      Size     File name
   -----------------------------------------------------
   08-11-2001  09:12  5.1.2600.19  927,232  Syssetup.dll
				

MORE INFORMATION

For this hotfix to work correctly in an OEM Preinstallation environment, you must slipstream the hotfix into the installation source directory (i386) before you install the operating system. If you do not do this, the original version of the Syssetup.dll file creates the \Windows\System32\Undo_GUImode.txt file, and you experience the symptoms that are described at the beginning of this article.

To slipstream the hotfix into the installation source directory, use the following steps:
  1. Rename the hotfix package to a file name that uses the 8.3 format.

    To do so, type the following line at a command prompt, where q###### is the Q-number of the Knowledge Base article that is associated with the hotfix, and then press ENTER:

    ren q######_wxp_spx_x86_enu.exe q######.exe

    NOTE: You must rename the hotfix file because Windows XP Setup does not recognize long file names.
  2. Make a temporary directory to hold the extracted contents of the hotfix package.

    To do so, type the following line at a command prompt, where q###### is the name of the hotfix package, and then press ENTER.

    md c:\q######

  3. Extract the files from the hotfix package. To do so, type the following line at a command prompt, where q###### is the name of the hotfix package, and then press ENTER.

    q######.exe /x

  4. When you are prompted for the folder in which you want to extract the files, type the following line, and then press ENTER:

    c:\q######

  5. Use a text editor such as Notepad to open the \Opktools\Lang\ENU\SKU\Pro\x86\i386\Dosnet.inf file.
  6. In the Dosnet.inf file, add the following lines, and then save and close the file.

    [OptionalSrcDirs]
    svcpack

  7. In the i386 folder, delete the Svcpack.in_ file, and delete any original files that are replaced by the files in the hotfix.
  8. Copy the replacement files from the temporary hotfix folder to the i386 folder. To do so, type the following line at a command prompt, where q###### is the name of the hotfix package, and then press ENTER:

    copy c:\q######\syssetup.dll c:\opktools\lang\enu\sku\pro\x86\i386\syssetup.dll

  9. In the \Opktools\Lang\ENU\SKU\Pro\x86\i386 folder, create a Svcpack folder.
  10. In the \Opktools\Lang\ENU\SKU\Pro\x86\i386 folder, use a text editor such as Notepad to create a new Svcpack.inf file that contains the following lines

    [Version]
    Signature="$Windows NT$"
    BuildNumber=2600
    MajorVersion=5
    MinorVersion=1

    [SetupData]
    CatalogSubDir="i386\svcpack"

    [ProductCatalogsToInstall]
    sp1.cat

    [SetupHotfixesToRun]
    q###### -q -n -z

    where q###### is the name of the hotfix package.
  11. Copy the Sp1.cat file from the c:\q######\Update folder to the C:\Opktools\Lang\ENU\SKU\Pro\x86\i386\Svcpack folder.

    To do so, type the following line at a command prompt, where q###### is the name of the hotfix package, and then press ENTER:

    copy c:\q######\update\sp1.cat c:\opktools\lang\enu\sku\pro\x86\i386\svcpack\sp1.cat

  12. Copy the Q######.exe file to the C:\Opktools\Lang\ENU\SKU\Pro\x86\i386\Svcpack folder.

    To do so, type the following line at a command prompt, where q###### is the name of the hotfix package, and then press ENTER:

    copy q######.exe c:\opktools\lang\enu\sku\pro\x86\i386\svcpack\q######.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbenv kbbug kbfix kbsetup kbWinXPsp1fix KB312368