You receive an open failure error message when you open an attachment in Outlook (312342)



The information in this article applies to:

  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002
  • Microsoft Outlook 2000
  • Microsoft Outlook 98
  • Microsoft Outlook 97
  • Microsoft Outlook Express 5.5 for Windows NT 4.0
  • Microsoft Outlook Express 5.01 for Windows NT 4.0
  • Microsoft Outlook Express 5.0 for Windows NT 4.0
  • Microsoft Outlook Express 4.0 for Windows NT 4.0
  • Microsoft Outlook Express 5.5 for Windows Millennium Edition
  • Microsoft Outlook Express 5.01 for Windows Millennium Edition
  • Microsoft Outlook Express 5.0 for Windows Millennium Edition
  • Microsoft Outlook Express 5.5 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.01 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.0 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.5 for Windows 98
  • Microsoft Outlook Express 5.01 for Windows 98
  • Microsoft Outlook Express 5.0 for Windows 98
  • Microsoft Outlook Express 5.5 for Windows 2000
  • Microsoft Outlook Express 5.01 for Windows 2000
  • Microsoft Outlook Express 6.0 for Windows 2000
  • Microsoft Outlook Express 6.0 for Windows Millennium Edition
  • Microsoft Outlook Express 6.0 for Windows 98 Second Edition
  • Microsoft Outlook Express 6.0 for Windows 98
  • Microsoft Outlook Express 6.0 for Windows NT 4.0

This article was previously published under Q312342

SYMPTOMS

When you open an attachment in Outlook, you may receive the following error message:
The file file name does not have a program associated with it for this action. To create an association, double-click My Computer on your desktop. On the View menu, click Options, and then click File Types.

CAUSE

This behavior can occur if the file attachment does not have a file name extension that is registered with a program on your computer. This behavior can also occur if the file attachment does not have any file name extension. For example, if you save a Notepad file without the .txt extension, the file name has no association to the Notepad program when the file is received as an e-mail attachment.

RESOLUTION

To resolve this behavior, associate a file type with the file:
  1. Right-click the attachment, and then click Open.
  2. Click Save it to disk, and then click OK.
  3. Click the desktop icon, and then click Save.
  4. Right-click the file, and then click Open With.
  5. Click the program that you want to associate the file with, and then click OK.

Modification Type:MajorLast Reviewed:12/13/2005
Keywords:kbattachments kbopenfile kbConfig kberrmsg kbprb KB312342