OLEXP: Error Message: MSIMN Caused an Invalid Page Fault in Module MSOE.dll (312333)



The information in this article applies to:

  • Microsoft Outlook Express 5.5 for Windows Millennium Edition
  • Microsoft Outlook Express 5.5 for Windows 98 Second Edition

This article was previously published under Q312333

SYMPTOMS

When you mark Newsgroup messages as Read, if you then change the view to Hide Read Messages, you may receive the following error message:
MSIMN caused an invalid page fault in module MSOE.dll

CAUSE

This behavior can occur if you have installed a more recent version of Directdb.dll, a version that does not match the current version of Outlook Express.

RESOLUTION

To resolve this behavior, use one of the following methods:
  • Manually extract the Directdb.dll file from the Mailnews.cab file.
  • If you are running Microsoft Windows 98 Second Edition (SE) and Microsoft Internet Explorer version 5, use Microsoft Windows System File Checker (SFC) to extract the Directdb.dll file from the installation disc.

How to Extract the File Manually

To manually extract the Directdb.dll file, you need the Mailnews.cab file that is available either on the Internet Explorer CD-ROM or on your hard disk. If you downloaded Internet Explorer from the Internet, this file is in the Windows Update Setup Files folder.
  1. In Windows Explorer, move the Mailnews.cab file from the CD-ROM or the Windows Update Setup Files folder to the Windows\System folder.
  2. Click the Start button, click Shut Down, click Restart in MS-DOS mode, and then click OK.
  3. Extract the Directdb.dll file from Mailnews.cab.For additional information about the extract utility, click the article number below to view the article in the Microsoft Knowledge Base:

    129605 How to Extract Original Compressed Windows Files

How to Extract the Files by Using System File Checker

  1. Insert the Windows 98 SE CD-ROM in the CD-ROM drive.
  2. Click the Start button, click Run, type Sfc.exe in the Open box, and then click OK.
  3. Under Select an option and click Start, click Extract one file from installation disk, type Directdb.dll, and then click Start.
  4. In the Restore from box, type the path to your CD-ROM. For example, if your CD-ROM drive is drive D, type d:\win98.
  5. Under Save file in, type c:\windows\system, and then click OK.

Modification Type:MinorLast Reviewed:7/13/2004
Keywords:kbenv kberrmsg kbprb KB312333