Visio2002: Error Message When You Open or Create a Drawing: Visio32.exe Has Generated Errors and Will Be Closed by Windows (312305)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Network Equipment

This article was previously published under Q312305

SYMPTOMS

When you attempt to open or create a new drawing in Microsoft Visio, you may receive a Dr. Watson error message similar to the following:
Visio32.exe has generated errors and will be closed by Windows. You will need to restart the program. An error log is being created.
You can find more details concerning this error message in the WinNT\drwtsn32.log file.

CAUSE

This behavior can occur if the default printer driver does not function properly or is not compatible with Visio.

RESOLUTION

To determine the cause of this behavior and then resolve the issue, use one or more of the following methods, as necessary.

Method 1: Determine Whether Your Driver Is Compatible with Visio

  1. Browse to the following Hewlett-Packard Web site:
  2. In the Enter product name and number box, type LaserJet III, and then click the arrow to the right of the box.
  3. When the search process is complete, click the drivers & downloads link next to the version of driver that you want to download.
  4. In the quick jump to dialog box, click the link for the operating system that is installed on your computer.
  5. Click the link for the available download.
  6. Read the given information, and then click the link provided in Step 3 of this Web page.
  7. In the Language dialog box, select the language that you want, and then click the Option 1 link to download the full version.

    NOTE: There may not be more than one option available.
  8. In the File Download dialog box, click Run this program from its current location, and then click OK.
  9. Follow the instructions to download and install the driver.NOTE: If these steps do not resolve the issue, proceed to Method 2.

Method 2: Reinstall the Printer Driver

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the list of installed programs, select your printer driver, and then click Add/Remove.
  4. Follow the instructions to complete the removal process.
  5. Insert your printer driver software.
  6. Click Start, point to Settings, and then click Control Panel.
  7. Double-click Add/Remove Programs.
  8. On the Install/Uninstall tab, click Install.
  9. Follow the instructions to complete the installation process.NOTE: If these steps do not resolve the issue, obtain an updated copy of your printer driver or proceed to Method 3.

Method 3: Disable Any Existing Fax Software When You Use Visio

NOTE: After you complete these steps, you need to reinstall your fax software.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the list of installed programs, select your fax software, and then click Add/Remove.
  4. Follow the instructions to complete the removal process.

MORE INFORMATION

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB312305