The Exchange MSSearch instance does not come online on a cluster and event IDs 3055 and 10006 are logged (310586)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Enterprise Server

This article was previously published under Q310586
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

The Exchange MSSearch instance does not come online on a Microsoft Windows 2000 Server cluster, and the following events are logged in the application event log:

Event 1

Event Type: Warning
Event Source: Microsoft Search
Event Category: Gatherer
Event ID: 3055
Description: The Gatherer property mapping file cannot be opened. Error: 80070002. The default values are being used. You may have to copy the property mapping file from the setup CD, or reinstall the program.

Event 2

Event Type: Error
Event Source: Microsoft Search
Event Category: Gatherer
Event ID: 10006
Description: An error occurred during the online operation for instance <Exchange MS Search Instance - (D-EXCLUVS1)>: 80070002 - The system cannot find the file specified.Depending on the root cause of the problem, you may also receive one or more of the following error messages:

Error message 1

80070002 - The system cannot find the file specified.

Error message 2

80070005 - Access is denied.

Error message 3

80070006 - The handle is invalid.

Error message 4

Error message 80070003 - The system cannot find the path specified.

CAUSE

When the Exchange MSSearch instance is brought online, MSSearch looks for configuration files that are present in the drive:\EXCHSRVR\ExchangeServer_Exchange Virtual Server Name folder. The names of these configuration files are Clust0.0, Clust0.1, Clust1.0, and so on.

The configuration files contain very important information about the Full Text Indexing application path, catalog paths, index paths, and more. These files are specific to the cluster and to the Exchange virtual server.

If the Exchange MSSearch instance cannot access the configuration files, the Exchange MSSearch instance does not come online, and the error messages that are mentioned in the "Symptoms" section appear.

The error messages may occur if one of the following conditions is true:
  • The ExchangeServer_Exchange Virtual Server Name folder or its content was removed or renamed (error 80070002).
  • The ExchangeServer_Exchange Virtual Server Name folder or its content was copied from a different server onto the clustered server (error 80070003).
  • The System account and the Administrator account do not have sufficient permissions to the ExchangeServer_Exchange Virtual Server Name folder or to its content (error 80070005).
  • The System account and the Administrator account do not have sufficient permissions to the HKLM\Software\Microsoft\Search\1.0 registry subkey or to its subkeys (error 80070005 or 80070006).

RESOLUTION

To resolve this problem, you must first determine the root cause of the problem by using utilities such as File Monitor (Filemon.exe) and Registry Monitor (Regmon.exe). To obtain these utilities, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

After you have determined the root cause of the problem, use one of the following methods to resolve this problem, depending on your situation:

Restore from a backup

If the ExchangeServer_Exchange Virtual Server Name folder or its contents have been replaced, deleted, or altered, restore the folder or its contents from a valid backup.

If the problem is with the Clust*.* files only, restore only those files.

If there is no valid backup of the ExchangeServer_Exchange Virtual Server Name folder and its contents, you can re-create the ExchangeServer_Exchange Virtual Server Name folder and its core files.

For more information about how to re-create this folder and its core files, click the following article numbers to view the articles in the Microsoft Knowledge Base:

282122 Server cannot bring the Microsoft Search resource online

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

830189 Exchange Server 2003 computer cannot bring the Microsoft Search resource online

You may have to rebuild the full-text indexes on the Exchange virtual server stores in Exchange System Manager.

Reset the NTFS file system permissions

Important Make sure that the System account and the Administrator account have Full Control permissions to the ExchangeServer_Exchange Virtual Server Name folder and its contents.

The Clust*.* files also require Full Control permissions for the Cluster Service account.

To reset NTFS permissions, follow these steps:
  1. Open Windows Explorer, and then locate the file or folder that you want to change permissions for.
  2. Right-click the file or folder, click Properties, and then click the Security tab.
  3. To set up permissions for a new group or user, click Add, type the name of the group or the user that you want to set permissions for by using the format domainname\name, and then click OK.
  4. To change or remove permissions from an existing group or user, click the name of the group or user, click Allow or Deny under Permissions for each permission that you want to allow or deny, and then click OK.

Reset registry permissions

Important Make sure that the System account and the Administrator account have Full Control permissions to the HKLM\Software\Microsoft\Search\1.0 registry subkey and all its subkeys.

To reset registry permissions, follow these steps:
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedt32, and then click OK.
  2. Maximize the HKEY_LOCAL_MACHINE subtree in the Local Machine window.
  3. Under the following subkey, locate the registry subkey that you want to reset permissions for:

    HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Search\1.0

  4. On the Security menu, click Permissions.
  5. To set up permissions for a new group or user, click Add, type the name of the group or the user that you want to set permissions for by using the format domainname\name, and then click OK.
  6. To change or remove permissions from an existing group or user, click the name of the group or user, click Allow or Deny under Permissions for each permission that you want to allow or deny, and then click OK.
  7. Quit Registry Editor
Important The valid folder and files must be established. Also, the System account and the Administrator account must have Full Control permissions to the ExchangeServer_Exchange Virtual Server Name folder, its contents, and the abovementioned registry subkeys.

Modification Type:MinorLast Reviewed:7/10/2006
Keywords:kbprb kberrmsg kbinfo KB310586