"Access Denied" Error Message When You Copy or Rename Files in the Recovery Console (308575)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP2
This article was previously published under Q308575 SYMPTOMS
By design, the Recovery Console only allows access to the following:
- The root folder.
- The %SystemRoot% folder and the subfolders of the Windows 2000 computer that you are currently logged on to.
- The Cmdcons folder.
- Removable media drives such as CD-ROM drives.
However, when you use the Recovery Console to rename, delete, or copy a file in the %SystemRoot% folder or one of its subfolders, you may
receive an "Access Denied" error message.
CAUSE
This issue can occur if the Everyone group has been removed from the %SystemRoot% folder or the volume that contains the %SystemRoot% folder.
RESOLUTION
To resolve this issue:
- Install a new installation of Windows 2000 onto a separate partition or drive.
NOTE: If the permissions have been changed on all partitions and disks on the computer, you may receive copy file error messages when you try to install Windows 2000. If this occurs, you may need to move the affected drive to another working Windows 2000-based computer to make permissions adjustments. - Start Windows 2000 (the new installation).
- Use Windows Explorer to give the Everyone group full control of the original volume's root folder and all system files and folders. You should now be able to boot to the original installation of Windows 2000.
- After a successful reboot into the original installation, use the information in the following Microsoft Knowledge Base article to re-apply default NTFS permissions to the computer:
237399 Default NTFS Permissions Not Applied to Converted Boot Partition
Modification Type: | Major | Last Reviewed: | 12/3/2003 |
---|
Keywords: | kbenv kberrmsg kbprb KB308575 |
---|
|