PRB: Exception in Ifc_com.dll Module (307862)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition
  • Microsoft FrontPage 2002
  • Microsoft Visual InterDev 1.0

This article was previously published under Q307862

SYMPTOMS

When you use Visual Studio .NET with the MERANT PVCS Version Manager, you may receive the following error message:
Unhandled exception has been caught by the Visual Studio Watson exception filter
The exception occurs in the Ifc_com.dll module. Alternatively, when you use the Recalculate Hyperlinks operation in Visual InterDev or FrontPage, the system stops responding (hangs).

If you use a debugger such as Dr. Watson, the beginning of the call stack appears as follows:

IFC_COM.DLL+0x29b2
					

CAUSE

This problem occurs because the Ifc_com.dll module is a MERANT dynamic-link library (DLL) and is installed with the PVCS source control product.

RESOLUTION

Although you can unregister this DLL to prevent this crash from occurring, you may experience unexpected results in the MERANT product if you unregister this DLL. Microsoft recommends that you contact MERANT to resolve this problem. For MERANT contact information, see the "More Information" section.

To unregister the Ifc_com.dll file, click Start, click Run, and then type the following command in the Open box:

regsvr32 /u drive letter:\path\ifc_com.dll

where drive letter and path are the drive and the path of the Ifc_com.dll file.

To register the Ifc_com.dll file, use the following command:

regsvr32 drive letter:\path\ifc_com.dll

MORE INFORMATION

You do not have to examine the call stack dump file to use this article. If you experience an unhandled exception when you use Visual Studio .NET, or if the system stops responding when you use FrontPage or Visual InterDev, and if you have MERANT PVCS Version Manager, you may want to use the resolution.

MERANT Technical Support requests that all customers, regardless of customer service contract status, contact them for internal document identification number 42747.

You can contact MERANT Technical Support at pvcs.answerline@merant.com, or at (800) 443-1601, or at (503) 617-2777.

There is a patch available from MERANT to resolve this behavior. If you are a registered MERANT user, you can locate a reference to this patch by visiting the MERANT Web site (http://support.merant.com), and then searching their knowledge base for article 512299.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:8/15/2005
Keywords:kbprb KB307862