FP2000: "Server Error" Error Message When You Attempt to Publish to a Server with the FrontPage Server Extensions Installed (307235)



The information in this article applies to:

  • Microsoft FrontPage 2000

This article was previously published under Q307235
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you attempt to publish your Microsoft FrontPage Web to a Web server on which the FrontPage Server Extensions are installed, you may receive the following error message
Server Error: Write error on file "path/file name.tmp"
where path is the directory path to which you are attempting to publish, and file name is the name of a file in the Web that you are attempting to publish.

CAUSE

This behavior can occur if one or more of the following conditions are true:
  • The Web server has insufficient storage space for the contents of your Web, or you have exceeded the maximum allowable storage space for your Web content on the server.
  • You do not have sufficient permissions to publish the Web.
  • A file in the Web that you are attempting to publish is corrupted.

RESOLUTION

To troubleshoot this issue, use the following methods in the order in which they are presented.

Method 1: Investigate Storage Issues on the Web Server

Contact your Web Presence Provider and verify that you have not exceeded the maximum storage space for your Web.

Method 2: Investigate Permissions Issues

Verify that you are able to publish a small Web to the server. If you are unable to do this, verify your permissions on the Web server. To do this, follow these steps.

NOTE: These steps assume that you are able to open a Web stored on the Web server.
  1. Start Microsoft FrontPage 2000, and then open the Web that you want.
  2. On the Tools menu, point to Security, and then click Permissions.
  3. View the assigned permissions for the various groups, users, and computers.
For additional information about setting permissions on a FrontPage Web, click the article number below to view the article in the Microsoft Knowledge Base:

216705 How to Set Permissions on a FrontPage Web on IIS

Method 3: Remove the File Specified in the Error Message

To determine whether this error message is caused by a corrupted file, remove the file from the FrontPage Web that you are attempting to publish. To do this, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Quit all running programs.
  2. Click Start, point to Search, and then click For Files or Folders.
  3. In the Search for files or folders named box, type the file name that is displayed in the file name portion of the error message that you receive when you attempt to publish the FrontPage Web.
  4. In the Look in list, select My Computer, and then click Search Now.
  5. In the Search Results pane, note the folder location of the file that you want.
  6. Start Windows Explorer, and then navigate to the location of the file that you want to remove.
  7. Right-click the file, and then on the shortcut menu that appears, click Cut.
  8. Navigate to, and then right-click, another folder on the hard disk, and then click Paste on the shortcut menu.

    The file is pasted into the alternate folder location on the hard disk.
  9. Quit Windows Explorer.
  10. Attempt to publish the FrontPage Web.

MORE INFORMATION

For additional information about troubleshooting FrontPage issues, click the article number below to view the article in the Microsoft Knowledge Base:

198431 Users Cannot Author, Permissions Are Set Correctly in FrontPage

260159 FPSE: Error Messages When You View Permissions in FrontPage

264761 FP98: Server Error When You Create a Web

264793 Server Extensions Error Received When Saving an .HTM File


Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kberrmsg kbprb KB307235