HP Pavilion 8766C does not connect to the Internet after upgrade from Windows 98 to Windows 2000 (306966)



The information in this article applies to:

  • Microsoft Windows 2000 Professional

This article was previously published under Q306966

SYMPTOMS

After you upgrade a Hewlett-Packard (HP) Pavilion 8766C computer from Microsoft Windows 98 to Windows 2000, the computer no longer connects to the Internet.

CAUSE

This behavior can occur because the HP Pavilion 8766C has a Chameleon combination modem/sound card that uses a Conexant chipset, and the driver for this card is not included on the Windows 2000 CD. The same symptoms may be seen on other HP computers that have the same modem/sound card.

RESOLUTION

To resolve this behavior, install the necessary modem and sound card drivers.

Installing Modem Drivers

  1. Make sure that there are no active parallel or direct cable connections.
  2. Download the driver for the HP Chameleon modem from the HP Web site at: The download includes drivers for all of the devices that are on the card (sound and modem). The download is a self-extracting zip file that goes into the C:\Chameleon_HSF_Win2000 folder.
  3. Restart the computer. Press F8 during startup to enter Safe mode.
  4. Point to Start, click Settings, click Control Panel, and then click System.
  5. On the Hardware tab, click Device Manager.
  6. Under Unknown Devices, right-click Simple PCI Communications device, and then click Properties.
  7. On the Drivers tab, click Update Drivers.
  8. In the Driver Update Wizard, click Search for updated driver, and then click Next.
  9. Click Specify a location, clear any other options, and then click Next.
  10. When you are asked to insert the manufacturer's disk in the drive, click Browse, and then browse to the C:\Chameleon_HSF_Win2000 folder, which contains the Chameleon drivers. Click the folder, and then click Open.
  11. Make sure that the NT52013.inf file is selected, and then click Open. Click OK in the Insert Disk dialog box that appears.
  12. When a message tells you that the driver is not digitally signed, click Yes to install the driver. Click Next to continue installation of modem drivers.
  13. If a prompt asks you to restart the computer, click Yes. Otherwise, click Finish, and then restart the computer.

    Remember to press F8 during startup to restart in Safe mode.

Installing Sound Card Drivers

  1. After you restart the computer in Safe mode, return to Device Manager. Under Unknown devices, right-click Multimedia Audio Device, and then click Properties.
  2. Click the Drivers tab, and then click Update Drivers. When the Update Drivers Wizard appears, click Search for updated driver, and then click Next.
  3. Click Specify a location, clear any other options, and then click Next.
  4. When you are asked to insert the manufacturer's disk in the drive, click Browse, and then browse to the C:\Chameleon_HSF_Win2000 folder, which contains the Chameleon drivers. Click the folder, and then click Open.
  5. Make sure that the Riptide.inf file is selected, and then click Open. Click OK in the Insert Disk dialog box that appears.
  6. A warning message may tell you that Windows 2000 cannot confirm that the driver matches your hardware. Accept the warning, and then continue. When you see the Digital signature not found warning message, click Yes to accept the warning, and then click Next to continue.
  7. If a prompt asks you to restart the computer, click Yes. Otherwise, click Finish, and then restart the computer.

    Remember to press F8 during startup to restart in Safe mode.
  8. After you restart the computer in Safe mode, return to Device Manager. Under Unknown devices, right-click PCI Input Device, and then click Properties.
  9. To finish installing the sound card drivers, follow Steps 2 through 7 of this procedure.

MORE INFORMATION

Some of the HP Pavilion computers contain a Rockwell Riptide modem, although the HP Web site may list them as containing a Chameleon modem. If the resolution procedure does not work after you install the Chameleon drivers, try the procedure again and install the Riptide drivers.

Modification Type:MinorLast Reviewed:7/18/2005
Keywords:kb3rdparty kbnetwork kbprb kbsound KB306966