Error Message: This Version Cannot Upgrade the Installed Version of Microsoft Small Business Server (306934)



The information in this article applies to:

  • Microsoft Small Business Server 2000

This article was previously published under Q306934
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you uninstall the Small Business Server (SBS) component of SBS 2000 from the SBS-integrated Setup, you may receive the following error message on the Suite Requirements page when you try to reinstall the SBS component:
This version cannot upgrade the installed version of Microsoft Small Business Server.

CAUSE

If the SBS group of programs cannot be completely uninstalled, it may not remove all of the associated registry entries.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue:
  1. Quit Setup.
  2. Start Registry Editor (Regedt32.exe).
  3. Click the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Small Business

  4. On the Registry menu, click Save key. Type a name for this file, and then click Save to make a backup of the key.
  5. Delete the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Small Business

  6. Restart the SBS 2000 Integrated Setup. Follow the instructions in the wizard, entering values as appropriate. When you reach the Component Selection screen, verify that SBS has its action set to Install. Follow the instructions to complete the wizard.
If you have added licenses to the Small Business Server computer prior to the removal and reinstallation of the Small Business Server component, you must re-apply the last successfully applied Add Pack to reset the Small Business Server Licenses. To re-add the licenses:

NOTE: It is important to not add New Client Add Packs until you have reapplied the last successfully applied Add Pack disk.
  1. Insert the last successfully applied Add Pack into the floppy drive.
  2. Click Start, click Run, type a:\setup.exe and then click OK to start the Add Pack Setup program. Follow the instructions in the wizard to apply the Add Pack.
  3. After the Add Pack has been applied, start the SBS Administrator console, view the "About" page and verify that the licenses have been set to the appropriate number. You may now apply new License Add Packs.

STATUS

This behavior is by design.

REFERENCES

287758 Removing BackOffice Server 2000 & SBS 2000 Temporary Setup Files


Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbenv kberrmsg kbprb kbsetup KB306934