OL2000: Only Recurring Appointments Appear When You Open a Resource Account Calendar (306643)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q306643

SYMPTOMS

When you open a resource account calendar in Outlook 2000, only recurring appointments appear. There are single-instance appointments in the calendar, but they do not appear.

If you select another week in the Calendar view, and select the original week again, all appointments appear as expected.

CAUSE

This behavior occurs because there is a damaged item in the resource account calendar. The recurrence pattern information in the first recurring appointment is missing or damaged.

RESOLUTION

Use the methods in this section to resolve this behavior.

Locate the Damaged Item

  1. Attach a personal folder (.pst) file to your installation of Outlook 2000.For additional information about how to create personal folders (.pst) files, click the article number below to view the article in the Microsoft Knowledge Base:

    195717 OL2000: (CW) How to Create a New Personal Folders (.pst) File

  2. Add a Calendar folder to the .pst file that you just created.
  3. On the View menu, click Current View, and then click By Category in the Resource Mailbox calendar.
  4. Select the first category in the list of the calendar, and then select all of the items in that category.
  5. Copy and paste the items that you selected to the calendar in the new .pst file.
  6. Select the calendar in the new .pst file. If you can view all of the items that were copied from the resource account calendar, repeat step 4 with the next category in the list until you cannot view certain items in the .pst calendar while you are in the Work Week view.
  7. After you have identified the category for the items that do not appear properly, re-copy half of the items in that category to verify if some of the items in that category do appear correctly. Drag small increments of the category to calendar of the new .pst file to continue to narrow down the affected item until you are can identify the item or items that are causing the behavior.

How to Repair the Damaged Item

  1. Double-click the damaged item.
  2. Click Recurrence.
  3. In the Range of Recurrence section, change the recurrence pattern, and then click OK.
  4. Click Save and Close, and then click Yes to save the changes.
  5. Click Exit and Log off.
  6. Re-start Outlook 2000.
  7. Select the calendar for the new .pst file where the item in question is stored.
  8. Double-click the item.
  9. Click Recurrence.
  10. In the Range of recurrence section, click No End Date, and then click OK.
  11. Click Save and Close, and then click No when you receive the prompt to send the item.
You should be able to see the previously damaged calendar item whenever you open the calendar in the new .pst file. You can copy the item back to the Resource Mailbox calendar on the Microsoft Exchange Server.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbprb KB306643