WD2000: A Password Dialog Box Appears When You Click the Back Button in Internet Explorer (306534)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.5 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.5 for Windows 2000 SP 2
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows 98
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer version 6 for Windows NT 4.0
  • Microsoft Internet Explorer version 6 for Windows XP
  • Microsoft Word 2000

This article was previously published under Q306534

SYMPTOMS

If you use Microsoft Internet Explorer to locate a Word document in a Web, and then you click Back, or you close the browser window, you may be prompted to type a user name and password.

The authentication dialog box also may appear if you start Word 2000, open a file as read-only directly from a Web server, and then close Word.

CAUSE

Internet Explorer is trying to write the document to the list of Most Recently Used (MRU) files. As a result, Internet Explorer tries to get read/write access to the document.

Internet Explorer tries to add the Word document to the MRU list when the client has a Web folder that points to the Web server where the Word document resides.

For example, you are browsing the Word document at "http://www.MyWebServer.com/word.doc", and you also have a Web folder that points to "http://www.MyWebServer.com". By default, the Web folder is trying to gain read/write access to the document.

WORKAROUND

To work around this problem, the preferred method is to delete the Web folder from your client computer. To do this, follow these steps:
  1. Quit any programs that you are using.
  2. On your Windows desktop, do one of the following:
    • In Microsoft Windows 98 or Microsoft Windows NT 4.0, double-click My Computer, and then double-click Web Folders.

      -or-
    • In Microsoft Windows Millennium Edition (Me), Microsoft Windows 2000, or Microsoft Windows XP, double-click My Network Places.
  3. Right-click the Web folder that points to the Web server that you want to delete, and then click Delete.

    Note If you are not sure of the location that a Web folder is pointing to, you can right-click the Web folder, and then click Properties. The Target is the location that the Web folder is pointing to.

RESOLUTION

A supported work around is also available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

When you navigate to a file in Internet Explorer, the work around documented in this article prevents the file from being added to the shell MRU list.

Note This behavior is by design. This behavior avoids the authentication prompt that typically occurs when the shell tries to add a file to the MRU list.

The English version of this fix should have the following file attributes or later:

   Date           Time     Version      Size        File name     
   -------------------------------------------------------------
   01-Feb-2002  18:39:04   9.0.0.6131   8,814,644   Winword.exe
				
Note After the hotfix is downloaded implement the registry key DontAddToMRUIfURL. To apply the key, double-click the QFE4214.reg file that is included with the hotfix package, and then click Yes to confirm that you want to add the information to the registry.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbnofix KB306534