Error Message When You Start Computer: Stimon Caused an Invalid Page Fault in Kernel32.dll (306393)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q306393
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry



If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

http://support.microsoft.com/default.aspx/w98?sid=460

SYMPTOMS

When you start your computer, one of the following behaviors may occur:
  • You receive a stop error (blue screen).

    -or-
  • You receive the following error message:
    Stimon caused an Invalid Page Fault in module Kernel32.dll.

CAUSE

This behavior occurs if a universal serial bus (USB) imaging device such as a scanner or Web camera is connected to the computer and if one of the following conditions is true:
  • The imaging device installation is corrupted.

    -or-
  • The imaging device has been uninstalled but the entry for Still Image Monitor (Stimon) remains in the Windows registry.

    -or-
  • The Stimon.exe file is damaged.

RESOLUTION

To resolve this issue, follow these steps.

Step 1: Rename the Stimon.exe File

  1. Unplug all USB devices.
  2. Insert a Windows Millennium Edition (Me) or Windows 98 Startup disk into your computer, and then start the computer to a command prompt.
  3. At the command prompt, type C:, and then press ENTER.
  4. Type CD\Windows\System, and then press ENTER.
  5. Type Rename Stimon.exe Stimon.old, and then press ENTER.
  6. Remove the Windows Startup disk.

Step 2: Start Windows in Safe Mode and Remove the Registry Entry

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Restart the computer. When the Power On Self Test (POST) is completed, press and hold down the CTRL key.

    The Windows 98 or Windows Me Startup menu appears.
  2. Use the ARROW keys to select Safe mode, and then press ENTER.
  3. In Windows Me, close the Help and Support window. In Windows 98, click OK on the Safe Mode message that appears.
  4. Click Start, and then click Run.
  5. In the Open box, type regedit, and then click OK.
  6. In Registry Editor, expand the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run

    If StillImageMonitor does not appear in the Name list in the right pane of the Registry Editor window, expand the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices

  7. On the Registry menu, click Export Registry File.
  8. In the Export Registry File dialog box, type Run Key in the File name box, and then click Save.

    The selected key is saved.
  9. In the right pane of the Registry Editor window, right-click StillImageMonitor, and then click Delete on the shortcut menu that appears.
  10. On the Confirm Value Delete message that appears, click Yes.
  11. Quit Registry Editor, and then restart the computer normally.

Step 3: Reinstall the Imaging Device

Follow the manufacturer's instructions to reinstall the USB imaging device. This replaces the registry entries and reinstalls the Still Image Monitor files.

MORE INFORMATION

For additional information about Still Image Monitor, click the article number below to view the article in the Microsoft Knowledge Base:

257815 Description of Still Image Monitor (Stimon.exe)


Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kberrmsg kbInvalidPageFault kbprb KB306393