PRB: Temp Folder with System Attribute Causes Errors in Visual FoxPro (306113)



The information in this article applies to:

  • Microsoft Visual FoxPro for Windows 5.0
  • Microsoft Visual FoxPro for Windows 5.0a
  • Microsoft Visual FoxPro for Windows 6.0
  • Microsoft Visual FoxPro for Windows 7.0

This article was previously published under Q306113

SYMPTOMS

When you try to save a form in step 4 of the Form Wizard, the following error may appear:
File C:\foxtest\<filename>.tmp does not exist. Error: 1
File C:\foxtest\<filename>.tmp does not exist.
Method: Formwizengine1.form1.SaveAs
Error: 0

CAUSE

The folder that Visual FoxPro uses to store its temporary files has the System attribute applied to it.

RESOLUTION

To resolve this problem, use one of the following workarounds:
  • From an MS-DOS command prompt, use the ATTRIB command to remove the System attribute for the folder:

    ATTRIB -S c:\temp

    Substitute the name of your Visual FoxPro temporary files folder for "temp" in the example. Note that Windows Explorer does not offer the option to change the System attribute from its interface.
  • Direct the Visual FoxPro temporary files to another folder that does not have the System attribute set.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Using the MS-DOS ATTRIB command, set the System attribute for the Visual FoxPro temporary files folder. For example, the syntax for a folder called "temp" on drive C would be as follows:

    ATTRIB +S c:\temp

    NOTE: To determine the location of the Visual FoxPro temporary files folder, use the SYS(2023) function.
  2. If Visual FoxPro is running, close it and then restart it.
  3. Start the Form Wizard, choose a table, and accept all the defaults in each step.
  4. When you reach step 4, click Finish.

Modification Type:MajorLast Reviewed:10/15/2002
Keywords:kbBug kbDSupport kbprb kbvfp600fix kbwizard KB306113