The Ntbackup.exe Tool Stops Responding When You Use the /t Parameter with a Scheduled Backup Job (306110)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Small Business Server 2000

This article was previously published under Q306110

SYMPTOMS

After you schedule Ntbackup.exe to run in Unattended mode and specify a tape by using the /t tape label name parameter, Ntbackup.exe may stop responding (hang) in the background before the requested tape is mounted.

To determine if this problem occurred, view the Processes tab in Task Manager to see if Ntbackup.exe is still running in the background. If you look in the Removable Storage Manager (RSM) work queue, a mount operation may not have been requested by the scheduled backup. If you start another interactive backup session, and then look at the backup report for the scheduled backup job, it may be totally blank.

CAUSE

This problem can occur if the tape that is requested by Ntbackup.exe is located in the RSM import pool. The Always move new import media to the backup media pool option is only honored when Ntbackup.exe is run interactively. Unattended backups do not automatically move import media for Ntbackup.exe to use even though that option was previously selected and saved in the user's profile. This may occur if you share tapes between computers, or if the tape was initially created by a non-RSM-aware program that writes directly to the tape by using the Microsoft Tape Format (MTF). Under these conditions, the tape resides in the import pool.

Although Ntbackup.exe should suppress all messages when it is running in Unattended mode, it generates the following message that requires user acknowledgment (by clicking OK):
Cannot locate the assigned media or backup device. This backup operation will terminate.
Because Ntbackup.exe is running in the background, the message cannot be answered, Ntbackup.exe continues to run in the background, and you must manually stop the Ntbackup.exe process on the Processes tab in Task Manager.

RESOLUTION

To work around this problem, manually move the tape from the import pool while you are in RSM to the backup pool prior to the scheduled Ntbackup.exe time. If you need to complete this operation in a completely unattended manner, you must create a batch file, and then schedule the batch file to run in place of the scheduled backup job. This procedure requires the Sleep.exe resource kit utility to ensure that enough time is given for some of these operations to complete. Copy the Sleep.exe file to the %systemroot%\System32 folder.

Bkup.cmd - Batch File Example

REM ***** START BATCH FILE ********

rsm refresh /lf"HP C1537A SCSI Sequential Device"
Sleep 60
rsm allocate /M"Backup\4mm DDS" /pf"SQL_BKUP"
sleep 10
C:\WINNT\system32\NTBACKUP.EXE backup "@C:\WINNT\Profiles\administrator\Local Settings\Application Data\Microsoft\Windows NT\NTBackup\data\systembkup.bks" /d "Unattended System Backup" /v:no /r:no /rs:no /a /hc:on /m normal /j "CDRIVE_JOB" /l:f /t "SQL_BKUP"

REM ******* FINISH BATCH FILE ******

In the preceding example, "HP C1537A SCSI Sequential Device" is the tape library name. You can extract your tape library name by running the rsm.exe view /tlibrary Rsm.exe command. In the preceding example, the tape that is named "SQL_BKUP" is in the RSM "Import\4mm DDS" pool.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows 2000.

MORE INFORMATION

For additional information about a similar issue, click the article number below to view the article in the Microsoft Knowledge Base:

295159 Scheduled Backups May Hang After Mounting Tape

For more information about the Ntbackup.exe command-line switches, click Start, click Run, type ntbackup /?, and then click OK.

Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbbug kbenv KB306110