Unable to Refresh Web Page That Uses Cookies if Set to Prompt for Cookies (306027)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows 98
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer version 6 for Windows NT 4.0
  • Microsoft Internet Explorer version 6 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows XP
  • Microsoft Internet Explorer version 6 for Windows XP 64-Bit Edition

This article was previously published under Q306027

SYMPTOMS

When you click the Refresh button on the Internet Explorer tool bar, and then click Refresh on the View menu (or press F5) to refresh a Web page that uses cookies, the Web page may not be successfully refreshed after you click Allow Cookie or Block Cookie in the Privacy Alert dialog box.

CAUSE

This problem can occur if Internet Explorer is configured to prompt for cookies in Advanced Privacy Settings or you imported an Internet Explorer privacy preferences (.xml) file that specified an action of prompt for cookies, and you refresh a Web page that sets or reads a cookie during the refresh process.

WORKAROUND

To work around this problem, click Default on the Privacy tab of Internet Options. You can then temporarily move the Privacy slider to Allow All Cookies (if you want the particular Web site to be able to set or read a cookie on your computer) or Block All Cookies (if do not want the particular Web site to be able to set or read a cookie on your computer), refresh the Web page, and then set your privacy settings back to Advanced or Import your Internet Explorer privacy preferences (.xml) file again.

If you imported an Internet Explorer privacy preferences file that specified an action of "prompt for cookies", you may need to completely remove the custom-imported settings and restore the default privacy settings.

For additional information about how to remove customized privacy settings that were imported, click the article number below to view the article in the Microsoft Knowledge Base:

301689 How to Restore Default Settings After Importing Custom Privacy Preferences

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbdisplay kbenv kbprb kbui KB306027