PRB: Application Center 2000 Service Pack 1 Setup Fails (304257)



The information in this article applies to:

  • Microsoft Application Center 2000

This article was previously published under Q304257

SYMPTOMS

Microsoft Application Center 2000 Service Pack 1 (SP1) installation may fail in the following scenarios:
  • At attempt to install from a shared CD-ROM drive fails and the following series of error messages appears:
    Application Center 2000 SP 1 setup could not locate a resource it requires. Click OK to browse for the Microsoft Application Center 2000.msi file.

    The feature you are trying to use is on a network resource that is unavailable.
    Click OK to try again, or enter an alternate path to a folder containing the installation package 'Microsoft Application Center 2000.msi' in the box below.

    Use feature from: 1

    "Error 1706. An error occurred while performing the task. No valid source could be found for product Microsoft Application Center 2000. The Windows Installer cannot continue. Verify that the Microsoft Application Center 2000 CD is in the CD-ROM drive, ..."
  • An attempt to install from a local CD drive may fail, and the following error messages appear:
    Application Center 2000 SP 1 setup could not locate a resource it requires. Click OK to browse for the Microsoft Application Center 2000.msi file.

    Please insert the disk: 1

CAUSE

Microsoft Application Center 2000 Service Pack 1 Setup may prompt you for the installation source during installation. If the installation source has an unrecognized volume label or the installation media being used has an unsupported stock keeping unit (SKU) number, Setup will fail to complete successfully.

The MSDN (Microsoft Developer Network) release of Microsoft Application Center 2000 was distributed with the CD labeled as "AC2000MSDN", which is an unrecognized label, so Setup fails to recognize it.

NOTE: Microsoft Application Center 2000 Service Pack 1 is not supported by the evaluation version of the application, so this version cannot be upgraded.

RESOLUTION

To resolve this problem:

  1. Create a new Microsoft Application Center 2000 CD that has a recognized label name (see the following table).
    +-------------------------------------------------------------------------+
    |Microsoft Application Center 2000 Labels and SKUs                        |
    +-------+----------+----------+----------+----------+----------+----------+
    |Version| Retail   | Select   | OPK      | ARK      | MSDN     |Evaluation|
    +-------+----------+----------+----------+----------+----------+----------+
    |Volume |AC2000STD |AC2000STD |AC2000OPK |AC2000ARK |AC2000DEV |AC2000EVL |
    |Label  |          |          |          |          |          |          |
    +-------+----------+----------+----------+----------+----------+----------+
    |SKU    | 1        | 1        | 2        | 3        | 4        | 5        |
    +-------+----------+----------+----------+----------+----------+----------+
    					
    NOTE: If you are uncertain which SKU is installed on a server, you can determine this by checking the following value in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Application Center Server\1.0\SkuType

  2. Copy the Microsoft Application Center 2000 files from the CD to a local disk.
  3. Copy the Microsoft Application Center 2000 files from the CD to a network share.
  4. Obtain and install a supported product SKU of Application Center 2000.
  5. Remove the Application Center 2000 CD from the drive.
  6. Obtain and install a supported product SKU of Application Center 2000.
  7. After you copy the Application Center 2000 CD to a local or network share, at a command prompt, run the Application Center Service Pack 1 file with the following switches for a unattended installation:

    acsp1setup.exe /path:"\\sharename" /unattended


Modification Type:MajorLast Reviewed:8/13/2002
Keywords:kbDSupport kbprb KB304257