PUB97: "Invalid VxD Dynamic Link Call" Error Message When You Click Picture Display (302824)



The information in this article applies to:

  • Microsoft Publisher 97

This article was previously published under Q302824
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you click Picture Display on the View menu in Microsoft Publisher 97, you may receive the following error message:
Invalid VxD dynamic link call from VWIN32(05) +0000 119E to device "0002", service 1.
Your Windows configuration is invalid. Run the Windows Setup program to correct this problem.

CAUSE

This behavior can occur if one (or more) of the following conditions is true:
  • The video driver installed on your computer is outdated.

    -or-
  • The video driver installed on your computer is not the correct driver.

    -or-
  • Video hardware acceleration is turned on.

RESOLUTION

To resolve this issue, use the following methods, as needed, in the order in which they are presented.

Method 1: Turn Off Graphics Hardware Acceleration

Microsoft Windows 95, Microsoft Windows 98, and Microsoft Windows Millennium Edition (Me)

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click Graphics.
  4. Move the Hardware Acceleration slider to the None setting.
  5. Click OK, and then click Close.
  6. When prompted to restart your computer, click Yes.

Microsoft Windows 2000

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Display.
  3. On the Settings tab, click Advanced, and then click the Troubleshooting tab.
  4. Move the Hardware Acceleration slider to the None setting, and then click OK.
  5. Click OK to close the Display Properties dialog box.

Method 2: Install the Latest Version of Your Video Driver

Contact your hardware manufacturer to obtain and install the latest version of the video driver for your video adapter.

For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

NOTE: If your computer already has the latest video driver installed, change the driver to an older version.

To identify the manufacturer and model of your video adapter, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. In Windows 95 or Windows 98, click the Device Manager tab.

    In Windows 2000, click the Hardware tab, and then click Device Manager.
  4. Click the plus sign (+) next to Display adapters to expand the branch.
  5. Under the Display adapters branch, note the manufacturer and model of your video adapter, and then click OK.
  6. Close all open windows.

MORE INFORMATION

For additional information about troubleshooting video problems in Windows 95 and Windows 98, click the article number below to view the article in the Microsoft Knowledge Base:

127139 Troubleshooting Video Problems in Windows


Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kberrmsg kbprb KB302824