FP98: "Unable to Access" Error Message When You Attempt to Publish Web to Personal Web Server (301589)



The information in this article applies to:

  • Microsoft FrontPage 98 for Windows

This article was previously published under Q301589

SYMPTOMS

When you attempt to publish a Microsoft FrontPage Web to your Microsoft Personal Web Server, you may receive an error message similar to the following:
Server Error: Unable to access configuration for Microsoft Personal Web Server.
NOTE: You have confirmed that the FrontPage Server Extensions are installed.

CAUSE

This behavior can occur when the Personal Web Server attempts to start before all of its dependent services are started. When this occurs, the FrontPage Server Extensions do not work, and the Personal Web Server does not start.

NOTE: Restarting the Personal Web Server does not resolve this issue.

RESOLUTION

To work around this issue, add the Personal Web Server program to the Microsoft Windows Startup group. By doing this, you allow more time for the PWS-dependent services to start before the Personal Web Server starts. To do this, follow these steps:
  1. Quit all running programs.
  2. Click Start, and then click Run.
  3. In the Open box, type msconfig, and then click OK.
  4. In the System Configuration Utility dialog box, click to clear the PWSTray check box on the Startup tab.
  5. Click Apply, and then click OK. You receive the following message:

    You must restart your computer before the new settings will take effect.
    Do you want to restart your computer now?

  6. Click No.
  7. Click Start, point to Settings, and then click Taskbar & Start Menu.
  8. In the Taskbar Properties dialog box, click Advanced on the Start Menu Programs tab.
  9. In the Folders pane, click the plus sign (+) to expand Programs.
  10. Click StartUp.
  11. On the File menu, point to New, and then click Shortcut.
  12. In the Create Shortcut dialog box that appears, type C:\Windows\System\Pwstray.exe in the Command line box, click Next, and then click Finish.
  13. On the File menu, click Close, and then click OK in the Taskbar Properties dialog box.
  14. Restart the computer.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kberrmsg kbprb KB301589