MSExchangeSA Terminates with Error 1067 After You Use DisasterRecovery Switch (301364)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

This article was previously published under Q301364

SYMPTOMS

After you perform a Disaster Recovery Setup of Exchange on a server, and then try to start the Microsoft Exchange System Attendant Service (MSExchangeSA), you may receive the following error message:
The service MSExchangeSA terminated unexpectedly with error 1067.
In addition, the following event ID messages may be logged in the Application event log and System log:

Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1005
User: N/A
Computer: SERVER
Description:
Unexpected error Access denied. Facility: LDAP Provider ID no: 80070005 Microsoft Exchange System Attendant occurred.

For more information, click http://search.support.microsoft.com/search/?adv=1.

-and-

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
User: N/A
Computer: SERVER
Description:
The Microsoft Exchange System Attendant service terminated unexpectedly. It has done this X time(s). The following corrective action will be taken in 0 milliseconds: No action.

CAUSE

This issue can occur if the server is missing critical security access to Active Directory to allow Exchange to function.

WORKAROUND

To work around this issue, run Exchange Setup without switches, and then click Reinstall for all components that should be installed on this server.

MORE INFORMATION

This issue usually occurs if the computer account for the server is deleted from Active Directory, and then added again when Microsoft Windows 2000 is reinstalled. This scenario can occur when you are required to perform a complete reinstallation of Windows 2000, for example, after a system drive failure, where you are starting with a fresh hard disk drive. The computer account is deleted instead of reset, and then it is re-added to Active Directory. This new computer account does not have all the required security in Active Directory to participate as an Exchange computer. When you use the /disasterrecovery switch, only the files that are needed for Exchange are copied; Setup does not do any security context checks or correct any files if they are missing.

In this scenario, it is recommended that you simply reset the computer account instead of deleting it from Active Directory. When you do so, the Security identification number (SID) of the computer account and all the Access Control Lists (ACLs) that that SID belongs to remain intact.

If you experience a failure of your system drive on your Exchange-based computer, and you do not have a system state backup, use the following method:
  1. Format the new drive, and then install Windows 2000 and the same Windows 2000 service pack as the original server.
  2. Start the Active Directory Users and computers snap-in, right-click the server, and then click Reset Account.

    Note Do not delete the account.
  3. Join the new server to the domain.
  4. Run Exchange Setup using the /disasterrecovery switch.
  5. Restore your backup of the databases to the server.
  6. Restart the Exchange-based computer, and then verify that the databases have mounted.
  7. If you encounter any security errors after this procedure (for example, an "access denied" message or the System Attendant fails to start), run the Reinstall program of Exchange. When you do so, any settings on the server are repaired.
If you try to reinstall Exchange on the server after you join the server to the domain, you may receive the following error message:
The server you are trying to install already exists in the Exchange Site
The /disasterrecovery switch does not try to add the server to the site; it only copies the files that are necessary to run Exchange. If you run the regular Setup of Exchange, and it does not detect that Exchange is already installed, it functions as if you are adding a new server to the site, and you receive the duplicate server error message that is described in this section.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kberrmsg kbprb KB301364