Visio2002: Installation of IntelliCAD 98 After Visio 2002 Breaks the CAD Features in Visio (300588)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional

This article was previously published under Q300588

SYMPTOMS

When you attempt to insert or open a CAD Drawing in Microsoft Visio, neither the Insert CAD Drawing nor the CAD Drawing Properties dialog boxes appear, and nothing is inserted into the drawing.

CAUSE

This problem may occur if you install IntelliCAD 98 after you install Microsoft Visio.

Both IntelliCAD and Visio install a file named VisioDWG.dll. The IntelliCAD version of this file starts IntelliCAD when you double-click an embedded .dwg file. The Visio version of this file opens the CAD Drawing Properties dialog box when you double-click a .dwg object in Visio, but has no knowledge of IntelliCAD.

The last product installed registers its version of VisioDWG.dll. If you install Visio after IntelliCAD, no other IntelliCAD functionality is affected. However, if you install IntelliCAD 98 after Visio, the .dwg display capabilities and features are essentially turned off in Visio.

RESOLUTION

To resolve this issue, repair Visio 2002 by using Control Panel. To do this, use the appropriate method for your operating system.

Microsoft Windows 2000

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Add/Remove Programs icon.
  3. Click Microsoft Visio Standard 2002 [English] or Microsoft Visio Professional 2002 [English], and then click Change.
  4. In the Microsoft Visio Maintenance Mode dialog box, click Repair, and then click Next.
  5. Complete the steps to repair (reinstall) Visio.

Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition (Me)

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click Add/Remove Programs.
  3. Click Microsoft Visio Standard 2002 [English] or Microsoft Visio Professional 2002 [English], and then click Add/Remove.
  4. In the Microsoft Visio Maintenance Mode dialog box, click Repair, and then click Next.
  5. Complete the steps to repair (reinstall) Visio.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbnofix KB300588