Visio2002: Visio Appears to Stop Responding When Listing Network Devices in Database Viewer (299997)



The information in this article applies to:

  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Enterprise Network Tools

This article was previously published under Q299997

SYMPTOMS

In a network diagram based on your AutoDiscovery database, when you double-click a device class in the Database Viewer to expand the group in the tree and view its contents, Microsoft Visio may appear to stop responding.

CAUSE

This behavior can occur when the database is very large (for example, a database that contains over 40,000 devices). When you expand sections of the database that contain a very large number of devices, it takes time for Visio to process and list the devices in the Database Viewer. The mouse pointer may or may not change to an hourglass icon during this operation.

RESOLUTION

To work around this issue, do either of the following:
  • Wait until Visio completes the process and displays the list of devices in the Database Viewer window.

    -or-
  • Create smaller databases by discovering sections of large networks. For example, rather than discovering your entire enterprise network, configure AutoDiscovery to discover a specific subnet, network, or range of Internet Protocol (IP) addresses.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The Database Viewer lists the contents of your AutoDiscovery database in tree view. The following device classes are displayed:

Routers
Hubs
Probes
Switches
Bridges
Servers
Printers
Workstations
Networks

To see a list of devices in your AutoDiscovery database, double-click the device class that you want to view.

For more information about the Database Viewer, type database viewer in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

For more information about discovering network devices, type discovering network devices in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kbpending KB299997