Error Message: "No Interfaces Have Been Registered" When You Click Remote Storage Manager (299943)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q299943

SYMPTOMS

When you click Removable Storage Manager (RSM) in Microsoft Management Console (MMC), you may receive the following error message:
No interfaces have been registered.
When you click OK to the error message, you are returned to MMC and RSM does not open. If you click RSM again, you will not see any error messages. The snap-in does not open. To see the error message again, you must quit and restart MMC. The error message only appears the first time you click Removable Storage Manager.
You may also notice that the Defrag utility does not operate and does not provide an error message.

CAUSE

This can happen if the global settings for Default Impersonation Level have been changed from Identify to Anonymous in Dcomcnfg.exe.

RESOLUTION

RSM requires the Default Impersonation Level to be set to Identify to function properly. To change this global setting, follow these steps.
  1. Click Start, click Run, and then type Dcomcnfg.
  2. Click the Default Properties tab.
  3. Click Identify in the Default Impersonation level box.
  4. Click Apply or OK.

Modification Type:MinorLast Reviewed:1/27/2006
Keywords:kberrmsg kbprb KB299943