"Error 1911. Could not register type library for" error message when you run the Office 2000 Setup program (299608)



The information in this article applies to:

  • the operating system: Microsoft Windows 98 Second Edition
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q299608
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

During the installation of Microsoft Office 2000, you may receive one or more of the following error messages
Error 1911. Could not register type library for c:\program files\msoffice\office\xl5en32.olb
Error 1911. Could not register type library for c:\program files\msoffice\office\EXCEL9.OLB
Error 1911. Could not register type library for c:\program files\msoffice\office\msoutl9.olb
and you are unable to start Microsoft Outlook or Microsoft Excel.

CAUSE

Cause 1

This behavior can occur when you upgrade from Microsoft Windows 98 to Microsoft Windows 98 Second Edition by using the upgrade CD-ROM. Under this scenario, Microsoft Data Access Components (MDAC) 2.5 may not be correctly installed.

Cause 2

This behavior can occur when your computer's CD-ROM drive or DVD-ROM drive reads data too quickly for the computer to process.

RESOLUTION

Cause 1

To resolve this issue, follow these steps:
  1. Rename the following files:

    C:\Program Files\Microsoft Office\Office\EXCEL9.OLB
    C:\Program Files\Microsoft Office\Office\XL5EN32.OLB
    C:\Program Files\Microsoft Office\Office\msoutl9.olb

  2. Insert the Office 2000 CD-ROM, click Start, click Run, and then type D:\setup /l*v c:\vlog1.txt. Click OK.

    This command runs the Office Setup program and creates a log file.
  3. Click Start, point to Settings, and then click Control Panel.
  4. In Control Panel, double-click Add/Remove Programs.
  5. Under Currently installed programs, click Microsoft Office 2000, and then click Change.
  6. In the Maintenance Mode dialog box, click Repair Office, click Repair errors in my Office installation, and then click to select the Restore my shortcuts check box. Click Finish.
  7. When the repair procedure is finished, restart your computer, and then start Microsoft Outlook.

Cause 2

To resolve this issue, use one of the following methods:
  • Try to install Office from a slower CD-ROM drive or DVD-ROM drive, if available.

    -or-
  • Temporarily reduce the caching setting for the CD-ROM drive or DVD-ROM drive to reduce the drive's performance level. To do this, see the "More Information" section of this article.

MORE INFORMATION

To reduce the caching setting for the CD-ROM drive or DVD-ROM drive, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click File System.
  4. On the CD-ROM tab, note the current settings, and then move the Supplemental Cache Size slider to the Small position.
  5. In the Optimize Access Pattern For box, click No Read-Ahead.
  6. Click OK, and then click Close.
  7. When you are prompted to restart your computer, click Yes.
  8. Install Office 2000, and then repeat steps 1 through 7, but in step 5 return the CD-ROM drive back to the settings noted in step 4.

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kbstartprogram kbsetup kberrmsg kbprb KB299608