Error Message: The TCP/IP Protocol Must Be Installed on this Computer Before Microsoft ActiveSync Can Be... (299409)



The information in this article applies to:

  • Microsoft Windows Powered Pocket PC 2003
  • Microsoft ActiveSync 3.6
  • Microsoft ActiveSync 3.5
  • Microsoft ActiveSync 3.1
  • Microsoft ActiveSync 3.0
  • Microsoft Windows 98 Second Edition

This article was previously published under Q299409
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to install ActiveSync and the InstallShield process reaches 99 or 100 percent, you may receive the following error message:
TCP/IP Protocol Required
The TCP/IP Protocol must be installed on this computer before Microsoft ActiveSync can be installed.

Click OK to quit Setup. Then, open Control Panel, double-click Network, and install the protocol.
Note that you may receive this error message even if Transmission Control Protocol/Internet Protocol (TCP/IP) is installed and appears to be working correctly.

CAUSE

This issue can occur if the Winsock2 registry key is missing, damaged, or contains information that relates to a product that modified the key.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue:
  1. Use Registry Editor (Regedit.exe) to export and then delete the following registry keys:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\Winsock(may not exist)
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\Winsock2

    NOTE: The purpose of exporting the preceding registry keys is to create a backup.
  2. Uninstall Dial-Up Networking:
    1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
    2. Click the Windows Setup tab.
    3. Click Communications, click Details, and then click to clear the Dial-Up Networking check box.
    4. Click OK, and then click OK. After you uninstall Dial-Up Networking, restart your computer.
  3. Reinstall Dial-Up Networking:
    1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
    2. Click the Windows Setup tab.
    3. Click Communications, click Details, and then click to select the Dial-Up Networking check box.
    4. Click OK, and then click OK. After you install Dial-Up Networking, restart your computer, and then install ActiveSync.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kberrmsg kbprb kbsetup KB299409