Visio2002: Visio Stops Responding When You Generate a Large Number of Network Reports (299209)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Enterprise Network Tools

This article was previously published under Q299209

SYMPTOMS

When you attempt to generate reports based on your AutoDiscovery and Layout network diagram, you may receive the following error message:
Microsoft Visio has encountered a problem and needs to close. We are sorry for the inconvenience.

The information you were working on might be lost. Microsoft Visio can try to recover it for you.

Restart Microsoft Visio.

Please tell Microsoft about this problem.

We have created an error report that you can send to help us improve Microsoft Visio. We will treat this report as confidential and anonymous.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature similar to the following:
   AppName: visio.exe AppVer: 10.0.525.4 ModName: vislib.dll
   ModVer: 10.0.525.4 Offset: 000c45b6
				
NOTE: The ModName entry in the error report signature may also be displayed as follows:

ModName: gdiplus.dll

CAUSE

This behavior can occur if you use the Network Reporting Wizard to generate a large number of network reports at any one time. For example, when you click to select all the report template check boxes to generate all reports that are available for your network diagram, the Visio Report Generation Status box is displayed, informing you of the progress of your reports. Then, after a period of time, Visio stops responding and you receive the error message described in the "Symptoms" section of this article.

RESOLUTION

To work around this issue, select only the report templates in the Network Reporting Wizard for the reports that you want to create. Or, if you want to generate all reports that are available for your network diagram, select a portion of the report template check boxes to create the first set of reports, and then start the Network Reporting Wizard again to select the remaining report template check boxes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The AutoDiscovery and Layout solution offers a wide range of predefined report templates that you can use to create tabular and textual reports about the status of your network. You can inventory IP addresses, summarize frame relay data, track changes to your network topology, and more.

For more information about generating network reports in Microsoft Visio, type network reports in the Ask a question box or the Answer Wizard, and then press ENTER to view the topics.

Modification Type:MinorLast Reviewed:7/27/2006
Keywords:kbbug kberrmsg kbpending KB299209