You cannot mount a database after an online restore operation (299000)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q299000

SYMPTOMS

When you perform an online restore of the Microsoft Exchange 2000 Server information store, you may not be able to mount the database. Additionally, the following event ID messages may be logged in the application event log:

Event Type: Warning
Event Source: ESE98
Event Category: Logging/Recovery
Event ID: 457
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description:
Information Store (3368) The log signature of the existing logfile E00.log doesn't match the logfiles from the backup set. Logfile replay cannot succeed unless all signatures match.

Event Type: Error
Event Source: ESE BACKUP
Event Category: Callback
Event ID: 904
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description:
Information Store (3368) Callback function call ErrESECBRestoreComplete ended with error 0xC8000262.

Event Type: Error
Event Source: ESE BACKUP
Event Category: Recovery
Event ID: 903
Date: 5/15/2001
Time: 3:52:56 PM
User: N/A
Computer: SERVERNAME
Description:
Information Store (3368) Restore from directory q:\tmp1\SG01 ended with error (Error returned from an ESE function call (-610).

If you try to mount the database by using Microsoft Exchange System Manager, you may receive the following error message:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

CAUSE

This behavior may occur if any one of the following conditions is true:
  • The Microsoft Exchange Information Store service is not running when you restore a backup of an Exchange store.
  • The signatures of the transaction logs do not match the signatures of the corresponding database.

    When you start the Exchange Information Store service manually, or if the Startup Type setting of the service is set to Automatic, the Exchange Information Store service tries to mount the database. When the Exchange Information Store service tries to mount the database, this action generates a new set of transaction logs. When you try to restore the information store at this stage, the Exchange Information Store service tries to match the signature of the database that you are restoring with the signature of the transaction logs that were created during startup. If the signatures of the transaction logs do not match the signatures of the corresponding database, the Exchange Information Store service cannot mount the database, and one or more of the event IDs that are listed in the "Symptoms" section may be logged in the application event log.

WORKAROUND

To work around this behavior, follow these steps:
  1. Make a new online backup of the current state of the information store; include both the database and the transaction logs. Make the new online backup even if the existing information store is corrupted. This action truncates the logs. To do this, follow these steps:
    1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.
    2. In the Welcome to the Windows 2000 Backup and Recovery Tools dialog box, click the Backup tab, and then locate and click the Exchange Server computers that you want to back up.

      Note If the box that you want to select appears to be unavailable, double-click Microsoft Exchange, or expand the Exchange Server tree. You can expand the tree down to the folder or down to the information store for any computer.
    3. Make sure that the files that are listed in the backup media or in the file name box are the files that you want to back up, and then click Start Backup.
    4. Verify the information in the Backup Job Information dialog box, and then click Start Backup.
    5. Click Close after you make sure that the back up job has completed successfully.
  2. Stop the Exchange Information Store service, and then delete all the database files and the log files that are in the Mdbdata folder. This action makes sure that there are no log files to match when the Exchange Information Store service is started. This action also makes it possible to avoid the event ID messages that that are described in the "Symptoms" section. To do all this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click Microsoft Exchange Information Store, and then click Stop.
    3. Make sure that the service stops successfully.
    4. Locate the drive where Exchange 2000 is installed, and then locate the following folder:

      \Program Files\Exchsrvr\Mdbdata

    5. Delete all the files that are in the Mdbdata folder.
  3. Restart the Exchange Information Store service, and then delete all the log files that are generated by the Exchange Information Store service when the Exchange Information Store service tries to mount the database. This action makes sure that there are no transaction logs for the Exchange Information Store service to match with the database that is going to be mounted. To do this, follow these steps:
    1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
    2. Right-click Microsoft Exchange Information Store, and then click Start.
    3. Make sure that the service starts successfully.
    4. Delete all files that are created by the Exchange Information Store service in the Mdbdata folder.
  4. To perform the restore operation, follow these steps:
    1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.
    2. In the Welcome to the Windows 2000 Backup and Recovery Tools dialog box, click the Restore tab.
    3. Locate the files that you want to restore, click the check boxes next to the files that you backed up, and then click Start Restore.
    4. In the Restoring Database Store dialog box, verify that the correct Exchange 2000 computer is listed in the Restore To box, and then type the location where you want to restore the log files to. For example, type: Program Files\Exchsrvr\Mdbdata.
    5. Click to select the Last Backup Set check box, click to select the Mount Database After Restore check box, and then click OK.
    6. In the Enter Backup File Name dialog box, select the file that you backed up in the Restore from backup file box, and then click OK.
    7. Verify that the restore operation is completed successfully, and then click Close.
    8. Verify that the Exchange Information Store service is running.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:12/24/2003
Keywords:kberrmsg kbprb KB299000