SNA Server/Host Integration Server May "Hang" When Using Generic Text Print Driver (298511)



The information in this article applies to:

  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 3.0 SP4
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3
  • Microsoft SNA Server 4.0 SP4
  • Microsoft Host Integration Server 2000
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP6a

This article was previously published under Q298511

SYMPTOMS

When you are printing with SNA Server 3.0 (or later) or Host Integration Server 2000 on a Windows NT 4.0 Server (with Service Pack [SP] 4 or later), all SNA Server/Host Integration Server print jobs may stop printing and eventually the server will "hang" (lock). When this occurs, all keyboard and mouse activity will cease.

This problem does not occur when running on Windows 2000 Server.

CAUSE

This problem is caused by a memory leak when you are using the generic text print driver. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

244350 Memory Leaks in 'Drsd' Tag When Printing to Generic Text Printer

RESOLUTION

To resolve this problem, apply the updated RASDD.dll file available from the link provided in the "Cause" section of this article.

MORE INFORMATION

The following information would be recorded if Performance Monitor were running during this time.

In one documented case of the problem, the following objects, counters, and instances were used:

Object = Process and Memory
Counter = Private Bytes and Pool Paged Bytes
Instance = SNASERVR, SNABASE and SNAPRINT

During this time you would see the process/private bytes for SNASERVR and SNABASE increase, level off, and then start to decrease, while SNAPRINT would remain in a steady state. However, when viewing the memory object on the pool paged bytes counter, you would observe a steady increase of paged bytes up until the point at which the server stops responding.

Reviewing the event viewer logs leading up to this failure would show the following errors:

SYSTEM LOG

Event 2020 - Source: Srv

The server was unable to allocate from the system paged pool because the pool was empty.
In addition to that event, a Snadump.log and Dr. Watson log (if configured as the default debugger) may be generated during this time as well:

APPLICATION LOG

Event 624 - Source: SNA Server (snadump)
Event 4097 - Source: DrWatson

Modification Type:MinorLast Reviewed:4/19/2005
Keywords:kbfix kbprb KB298511