Windows Installer prompts you for an Office 2000 CD, or you receive an "Error 1706" error message after you start a program that uses the Mscomctl.ocx file (298385)



The information in this article applies to:

  • Microsoft Office 2000 Standard, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Office 2000 Developer, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Office 2000 Premium, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Office 2000 Professional, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft Office 2000 Small Business, when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q298385

SYMPTOMS

When you start an application that uses the Mscomctl.ocx file, the Windows Installer may do one of two things, depending on whether you are a member of the Administrators group:
  • If you are logged on as a member of the Administrators group, you are prompted for the Office CD.
  • If you are not a member of the Administrators group, you are not prompted for the Office CD, but you receive the following error message:
    Error 1706. No valid source could be found for product Microsoft Office 2000 edition. The Windows Installer cannot continue.
    In the error message, edition is the edition of Office that you installed, for example, Microsoft Office 2000 Premium.
The following text is taken from a Windows Installer log file that was created when verbose logging was enabled through the registry and the Windows Installer appeared in this situation:
******* Product: {00000409-78E1-11D2-B60F-006097C998E7}
******* Action: 
******* CommandLine:  REINSTALL=ProductNonBootFiles REINSTALLMODE=pocmus
MSI (c) (58:58): Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (58:58): Grabbed execution mutex.
MSI (c) (58:58): Cloaking enabled.
MSI (s) (C0:38): Resetting cached policy values
MSI (s) (C0:38): ******* RunEngine:
******* Product: {00000409-78E1-11D2-B60F-006097C998E7}
******* Action: 
******* CommandLine:  REINSTALL=ProductNonBootFiles REINSTALLMODE=pocmus 
				
Also, in this situation, the following events appear in the application event log:

Event 1001:

Detection of product '{00000409-78E1-11D2-B60F-006097C998E7}',
feature 'ProductNonBootFiles' failed during request for component
'{22056900-C842-11D1-A0DD-00A0C9054277}'

Event 1004:

Detection of product '{00000409-78E1-11D2-B60F-006097C998E7}',
feature 'ProductNonBootFiles', component
'{4A31E933-6F67-11D2-AAA2-00A0C90F57B0}' failed

CAUSE

You may experience this problem if all of the following conditions are true:
  • Your computer is running Microsoft Windows 2000.
  • Office 2000 is installed on your computer.
  • You used a CD to install Office.
  • You did not start any of the Office programs yet.
  • You start a third-party program that uses Mscomctl.ocx.
Certain registry data only exists in your user profile after you start one of the Office programs. Because of the feature-component relationship between the Mscomctl.ocx control and this registry data, the Windows Installer repairs the Office installation to ensure the existence of this registry information.

If you are not logged on as a member of the Administrators group, you do not have sufficient permissions to repair the Office installation in this scenario, and you are not prompted for the Office CD. Therefore, you only receive the 1706 error message.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Start an Office Program

The easiest way to resolve this problem is to start any of the Office 2000 programs. When you start an Office program, the necessary information is automatically written into the Windows registry. At this point, you can quit the Office program and then start the third-party program. The Windows Installer does not appear, because it no longer needs to repair the missing registry information.

Method 2: Install Office from an Administrative Installation

When you install Office from an administrative installation, the Windows Installer uses that installation as the source for the Office files during any repair operation. Therefore, even if the Windows Installer appears when you start the third-party program, you are not prompted for the Office CD, and the necessary repair automatically occurs, using the files on the administrative installation. This is true whether or not you are part of the Administrators group.

NOTE: If you do not have access to the Office administrative installation (for example, you are not connected to your network), the Windows Installer prompts you for a valid Office source location.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

284273 OFF2000: How to Deploy Office over a Network

Method 3: Apply the AllowLockdownMedia Policy

If you are not logged on to the Administrators group, you are not prompted for the Office CD, and you instead receive the 1706 error message. As a non-administrative user, you do not have the necessary permissions.

In this situation, you can apply the AllowLockdownMedia policy, which causes the Windows Installer to prompt for the Office CD during the repair process. To apply this policy, follow the steps in the following Knowledge Base article:

258847 OFF2000: Error Message: "The Feature You Are Trying to Use Is on a Network Resource That Is Unavailable" or "Error 1706"


Modification Type:MinorLast Reviewed:9/14/2004
Keywords:kbtshoot kbprb kbstartprogram kberrmsg KB298385