404 Error Occurs When You Browse to the OMA55 Virtual Root After You Reinstall Mobile Information Server (298169)



The information in this article applies to:

  • Microsoft Mobile Information 2001 Server

This article was previously published under Q298169

SYMPTOMS

After you remove Mobile Information Server, and then reinstall it, the Exchange Server 5.5. Data Provider (OMA55) may become inoperable. When you access the OMA55 virtual root, you may receive the following error message:
HTTP 404 Error, File not found.

CAUSE

When you remove Mobile Information Server, and then reinstall it, if the Internet Information Service Administrator (IISAdmin) service is stopped, the OMA55 virtual root is not deleted. In this case, OMA55 is not registered as a program; it is registered as a standard virtual root.

WORKAROUND

To work around this issue, after you remove Mobile Information Server, ensure that all the virtual roots are removed from Internet Information Service (IIS) before you reinstall the program:
  1. On the Mobile Information Server computer, click Start, click Programs, click Administrative Tools, and then click Internet Services Manager.
  2. Click to expand your server, and then click to expand Default Web Site.
  3. Confirm that the following virtual roots or programs are not listed.
    • MMISNotify
    • MMISDeviceInfo
    • OMA
    • In
    • OMA55
  4. If OMA55 exists, right-click OMA55 Virtual Root, and then click Delete.
  5. Restart the IISAdmin service and related services.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB298169