CRS Sockets Leak When SMTP Server Is Unreachable (298150)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q298150

SYMPTOMS

When you configure Content Replication System (CRS) to send an e-mail report, if the Simple Mail Transport Protocol (SMTP) server is unreachable or misconfigured, the SMTP event sink may loop indefinitely and consume all sockets resources that are available on the system. This may lead to several problems:
  • CRS may use all available user ports on the system.
  • Sockets leak.
  • Sockets resources are no longer available for other services. Some services may fail due to the lack of available sockets resources.

CAUSE

For each attempt to connect to the SMTP server, CRS creates a Transmission Control Protocol (TCP) socket. This problem occurs because the socket is not closed in case of failure.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Site Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date       Time    Version      Size    File name     Platform
   -----------------------------------------------------------------------
   05/04/2001 12:45a  7.0.1318.0   51,504  Crssinkm.dll  x86 
				

STATUS

Microsoft has confirmed that this is a problem in Site Server 3.0.

MORE INFORMATION

The retry interval can be configured based on the MailRetryPeriod registry value under the HKLM\Software\Microsoft\CRS\EventLogging\Mail registry key. The default setting is 60000 (1 minute).

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB298150