PRB: Active Documents Appear Blank in Internet Explorer When They Are Not Cached (297822)



The information in this article applies to:

  • Microsoft Internet Explorer (Programming) 4.0
  • Microsoft Internet Explorer (Programming) 4.01
  • Microsoft Internet Explorer (Programming) 4.01 SP1
  • Microsoft Internet Explorer (Programming) 4.01 SP2
  • Microsoft Internet Explorer (Programming) 5
  • Microsoft Internet Explorer (Programming) 5.01
  • Microsoft Internet Explorer (Programming) 5.01 SP1
  • Microsoft Internet Explorer (Programming) 5.5

This article was previously published under Q297822

SYMPTOMS

When you open a document (such as .doc files, .xls files, .pdf files, or any other file that will be viewed "in place" inside Internet Explorer) from a Web server, the document fails to appear, even though the correct viewer is loaded. In addition, you receive an error message, which states that the document could not be found (or similar error message).

CAUSE

When Internet Explorer uses an Active Document server, such as Microsoft Word, to display a document within the Internet Explorer window, the server must be pointed to a file. Generally, this file is the cached copy of the document that was retrieved. If the HTTP headers instruct the browser not to cache the document, the Active server (the viewer for that document) has no file to read and fails.

RESOLUTION

If a document is intended to be viewed in this way, do not include any cache-control information with the HTTP headers.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Place a .doc file on your Web server.
  2. Link to that file from an HTML page.
  3. Configure the server so that it sends a no-cache header with the page. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

    189409 INFO: Controlling the caching of Web pages with IIS 4.0

  4. In Internet Explorer, open the HTML page, and browse to the linked .doc file. Notice that the page appears blank, and you receive an error message, which varies according to the version of your operating system, Internet Explorer, and Microsoft Office.

REFERENCES

For additional information about the caching of content in Internet Explorer, click the following article number to view the article in the Microsoft Knowledge Base:

234067 How to prevent caching in Internet Explorer

For additional information about the in-place activation of documents such as Microsoft Word, Microsoft Excel, or .pdf files, click the following article number to view the article in the Microsoft Knowledge Base:

259970 PBR: In-place activating document servers in Internet Explorer

For additional information about similar issues when you view Word and Excel documents, click the following article number to view the article in the Microsoft Knowledge Base:

185978 FIX: Double GET requests and cookies are lost with Word 2000 or Excel 2000

For more information about developing Web-based solutions for Microsoft Internet Explorer, visit the following Microsoft Web sites:

Modification Type:MajorLast Reviewed:5/11/2006
Keywords:kbActiveDocs kbCaching kbprb KB297822