FP98: Error Message When You Perform a Search in a Web Site (296820)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows
- Microsoft FrontPage 97 for Windows
This article was previously published under Q296820 SYMPTOMS
When you attempt to perform a search in a web site, you receive an error message similar to the following:
HTTP Error 405 Method not
allowed
CAUSE
This behavior can occur in the following situation:
- You create a FrontPage Server Extensions-based Web site.
- You create a database Search form that searches the web site using Microsoft Index Server.
- You install Microsoft Site Server on the Web server.
This behavior can also occur when you recalculate hyperlinks with the fpsrvadm.exe command-line utility and you do not specify a port or you specify all ports. For example:
fpsrvadm.exe -operation recalc -port all<ENTER>
The <base href=http://entry/filename> tags in all HTML Extension (.htx) files are changed to <base href=http:///filename>. The .htx files no longer work.
RESOLUTION
To resolve this issue, recalculate hyperlinks on the web site. To do this, follow these steps:
- On the server computer, start a command prompt.
- Change to the directory that contains the fpsrvadm.exe utility. For example:
C:\Program Files\Microsoft FrontPage\Version3.0\Bin
- Type one of the following Fpsrvadm.exe commands depending on your web site configuration
Fpsrvadm.exe -operation recalc -port ip address:80
(where ip address is the IP Address of the web site that you want)
-or-
Fpsrvadm.exe -operation recalc -port host name:80
(where host name is the Host name of the web site that you want)
and then press ENTER. For example: fpsrvadm.exe -operation recalc -port 192.168.1.100:80 <ENTER> - At the Enter web name []: prompt that appears, press ENTER.
The links are recalculated for the specified web site, and the HTTP Extension (.htx) files are corrected.
Modification Type: | Minor | Last Reviewed: | 1/7/2006 |
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Keywords: | kbprb KB296820 |
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