BUG: Error "Pipeline.dll Failed to Register" During Uninstallation of Commerce Server 2000 SP1 (296352)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q296352

SYMPTOMS

During the Commerce Server 2000 SP1 uninstallation, you may receive the following error message:
Commerce Server 2000

Error 1904.Module D:\Program Files\Microsoft Commerce Server\pipeline.dll failed to register. HRESULT -2146368508. Contact your support personnel.
The following events are logged in the Event Log:
Failed to register COM+ component CommercePipeline. HRESULT 0x80110404.

-and-

The description for Event ID ( 12293 ) in Source ( Commerce Server 2000 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: D:\Program Files\Microsoft Commerce Server\pipeline.dll could not register itself with the Microsoft Transaction Server (MTS). This may be because the components are already registerd with MTS. To remove this component from MTS, run the Transaction Server Explorer. Select this server and select the property view. Navigate through each installed package until you find one with components Commerce.MtsPipeline and Commerce.MtsTxPipeline. Delete every instance of these components. NOTE: Deleting these entries may cause other applications to stop functioning. Once you have deleted all entries successfully, re-run setup for Site Server, Commerce Edition..

-and-

Product: Commerce Server 2000 -- Error 1904.Module D:\Program Files\Microsoft Commerce Server\pipeline.dll failed to register. HRESULT -2146368508. Contact your support personnel.

CAUSE

Pipeline.dll cannot be registered if the Microsoft COM+ CommercePipeline application has been changed as follows:
  • COM+ CommercePipeline application is renamed.
  • Any of the following components has been changed, deleted, or moved to other applications:
    • Commerce.MtsPipeline
    • Commerce.MtsTxPipeline Commerce.PooledPipeline
    • Commerce.PooledTxPipeline
    • CS_Req.PrivateOrderGroupMtsHelper
    • CS_Req.PrivateOrderGroupMtsTxHelper

RESOLUTION

To work around this problem, use one of the following methods:
  • Rename the COM+ application "CommercePipeline" if it is different.
  • Move the necessary components back to CommercePipeline if they are in other COM+ applications.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Install the following products and services:
    • Microsoft Windows 2000
    • Microsoft Internet Explorer 5.5
    • Microsoft SQL Server 2000
    • Microsoft SQL Server OLAP Services 2000
    • Windows 2000 Service Pack 1 (SP1)
    • Microsoft Commerce Server 2000 (a complete installation on one computer)
    • Retail Site
    • Commerce Server 2000 SP1


  2. From the Windows Start menu, point to Programs, point to Administrative Tools, and then click Component Services.
  3. In Component Services, rename CommercePipeline to CommercePipeline1.
  4. In Control Panel, click Add/Remove Programs. Click Commerce Server 2000 SP1, and then click Remove to uninstall Commerce Server 2000 SP1. You receive the above-mentioned error message.
  5. From the Start menu, point to Programs, point to Administrative Tools, and then click Event Viewer. Notice the above-mentioned events are logged in the Event Log.

Modification Type:MajorLast Reviewed:10/17/2002
Keywords:kbbug KB296352