Error Message When You Log on to AOL (296081)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q296081

SYMPTOMS

When you attempt to connect to America Online (AOL), you receive the following error message:
waol has caused an error in amsvcr.dll

NOTE: You receive the error message at Step 7 of the logon process.

CAUSE

This behavior can occur when the following Windows system files are missing or damaged:

Wsock32.dll
Wsock.vxd
Msacm.dll

RESOLUTION

To resolve this issue, replace the missing or damaged Windows system files. To do this, follow these steps.

NOTE: The following steps assume that Microsoft Windows is installed on drive C. If Windows is not installed on drive C, substitute the correct drive letter where appropriate.
  1. Start the computer using a Microsoft Windows 98 Startup Disk. On the Microsoft Windows 98 Startup menu, select Start computer with CD-ROM support.
  2. Type C:, and then press ENTER.

    Note the drive letter assigned to the CD-ROM when you boot from the startup disk. It is usually one letter greater than when Windows is running.
  3. Type CD\Windows\System, and then press ENTER.
  4. Type Rename Msacm.dll Msacm.old, and then press ENTER.
  5. Type Rename Wsock.vxd Wsock.old, and then press ENTER.
  6. Type Rename Wsock32.dll Wsock32.old, and then press ENTER.
  7. Insert your Windows 98 CD-ROM in your CD-ROM drive.
  8. Type A: and then press ENTER.
  9. Type Ext and then press ENTER. The Microsoft Extract Command Line Helper starts.
  10. At the Please enter the path to the Windows CAB files (a:) prompt, type E:\WIN98, and then press ENTER.

    NOTE: If your CD-ROM drive has been assigned a letter other than E, substitute that letter in this step.
  11. When you are prompted to enter the name of the file or files you want to extract, type Msacm.dll Wsock32.dll Wsock.vxd, and then press ENTER.

    NOTE: You must leave a space between each of the file names.
  12. When you are prompted to enter the path to extract to, type C:\WINDOWS\SYSTEM, and then press ENTER.
  13. At the Is this okay? (y/n) prompt, type Y, and then press ENTER.
  14. After the files are extracted, restart the computer.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbfix kbgpf kbInvalidPageFault kbprb KB296081