You receive a "Microsoft Access couldn't print your object" error message (294552)



The information in this article applies to:

  • Microsoft Office Access 2003
  • Microsoft Access 2002

This article was previously published under Q294552
Novice: Requires knowledge of the user interface on single-user computers.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

For a Microsoft Access 2000 version of this article, see 224151.

ERROR MESSAGE

When you try to preview or print a report in Microsoft Access, you receive the following error message:
Microsoft Access couldn't print your object. Make sure that the specified printer is available.

CAUSE

Microsoft Access cannot communicate with the printer.

RESOLUTION

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

The regional settings for your computer may be corrupted

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Regional Settings.
  3. On the Regional Settings tab, select a different setting from the list (there are several country settings that use English), and then click OK.
  4. Restart your computer.
  5. On the Regional Settings tab in Control Panel, select your original regional setting again.
  6. Click OK, and then restart your computer.

If you are using a network printer, the printer driver may require that the printer port is captured

Before beginning this procedure, check with your network administrator to make sure you have the correct path for the network printer.
  1. Click Start, point to Settings, and then click Printers.
  2. Right-click the icon for your printer, and then click Properties.
  3. On the Details tab, click Capture Printer Port.
  4. In the Device box, click a port that is not used by another printer.
  5. In the Path box, type the network path to the printer, and then click OK to close the Capture Printer Port dialog box.
  6. In the Print to the following port box, click the port that you selected in step 4, and then click OK.

The printer may have an invalid network name

Before beginning this procedure, check with your network administrator to make sure that you have the correct name and path for the network printer.
  1. Click Start, point to Settings, and then click Printers.
  2. Right-click the icon for your printer, and then click Properties.
  3. On the Details tab, click Delete Port.
  4. In the Delete Port dialog box, select the printer that you want to remove, and then click OK.
  5. On the Details tab, click Add Port.
  6. In the Add Port dialog box, click Network and type the network path to the printer, and then click OK.
  7. In the Print to the following port box, select the port that you entered in step 6, and then click OK.

The printer driver may be corrupted

  1. Click Start, point to Settings, and then click Printers.
  2. Right-click your default printer, and then click Delete. If you are asked if you want to remove extra files left on the system, click Yes.
  3. Double-click Add Printer, and then follow the instructions to reinstall your printer driver.

    When you reinstall your printer driver, Microsoft Windows corrects many system files and registry keys.
NOTES:
  • If your printer model is not listed in the Manufacturers and Printers lists, check the Hardware Compatibility list (HCL) for an updated driver. If your printer is not on the HCL, contact the printer manufacturer for drivers and instructions.
  • If you are on a network, you may have to install the correct printer driver from a network printer share. Contact your network administrator for instructions.

REFERENCES

For information about how to contact your printer manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:12/2/2005
Keywords:kbprintpreview kbprinters kbprint kberrmsg kbprb KB294552 kbAudDeveloper