XADM: Event ID 904, 8012, 8010, and 8003 Messages Are Logged When You Restore a Database from Backup (291996)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q291996

SYMPTOMS

When you try to restore an Exchange 2000 Server database from an online backup, the backup procedure is completed; however, some files are skipped. In addition, the following error messages are logged in the Application log of Windows NT Event Viewer:

Event Type: Error
Event Source: ESE BACKUP
Event Category: Callback
Event ID: 904
Description:
Information Store (2500) Callback function call ErrESECBRestoreGetDestination ended with error 0xC7FE1F41 Database is in use.

-and-

Event Type: Error
Event Source: NTBACKUP
Event Category: Callback
Event ID: 8012
Description:
The 'Microsoft Information Store' returned 'Database is in use. ' from a call to 'HrESERestoreAddDatabase()' additional data 'Private Information Store (Server_name)'

-and-

Event Type: Error
Event Source: NTBACKUP
Event Category: Callback
Event ID: 8010
Description:
Microsoft Exchange services returned 'ffffffff' from a call to 'MungeFname()' additional data 'C:\ExchSrvr\Mdbdata.Priv.edb'

-and-

Event Type: Error
Event Source: NTBACKUP
Event Category: Callback
Event ID: 8003
Description:
End Restore to 'Server_name\Microsoft Information Store\First Storage Group' Verify: Off

NOTE: The absolute path to the Mdbdata folder may vary on a particular server. The C:\ExchSrvr path is used in this article as an example of a typical path.

CAUSE

This issue can occur if the database is not dismounted and if the option to enable the database to be overwritten by a restore operation has not been enabled on this database before you run NTBackup.

RESOLUTION

To resolve this issue, use the following procedure before you run NTBackup:
  1. Start Exchange System Manager, right-click the database that you want to restore, and then click Dismount Store.
  2. When you are asked if you want to dismount the store and disconnect any users, click Yes.
  3. Right-click the store again, and then click Properties.
  4. Click the Database tab, and then click to select the This database can be overwritten check box.

MORE INFORMATION

If you are only restoring the mailbox store or public folder store of a particular storage group, similar events may also be logged. To resolve this issue, use the same procedure that you use when you restore the mailbox store and public folder store together.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

253299 XADM: Windows 2000 Backup Does Not Dismount Databases During the Restore Process

253931 XADM: Mounting a Database After Restore Fails with Error c104172

232938 XADM: The Last Backup Set Check Box and Hard Recovery in Exchange 2000

258243 XADM: How to Back Up and Restore an Exchange 2000 Server Computer by Using the Windows Backup Program


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB291996